summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-02 21:56:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-02 22:05:19 +0300
commitb6c2d8831b8d3e810e829a42c5139703aaa030f6 (patch)
tree3b36bd3e1ec5a712707b64f21ad6311e84ece1a0 /dev-python/publicsuffix
parentdev-python/dkimpy: enable py3.10, small cleanup (diff)
downloadgentoo-b6c2d8831b8d3e810e829a42c5139703aaa030f6.tar.gz
gentoo-b6c2d8831b8d3e810e829a42c5139703aaa030f6.tar.bz2
gentoo-b6c2d8831b8d3e810e829a42c5139703aaa030f6.zip
dev-python/publicsuffix: enable py3.10, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/publicsuffix')
-rw-r--r--dev-python/publicsuffix/Manifest1
-rw-r--r--dev-python/publicsuffix/publicsuffix-2.20191221-r1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/publicsuffix/Manifest b/dev-python/publicsuffix/Manifest
index 9eeb3b3d194f..ced5546f5042 100644
--- a/dev-python/publicsuffix/Manifest
+++ b/dev-python/publicsuffix/Manifest
@@ -1 +1,2 @@
+DIST publicsuffix-2.20191221.gh.tar.gz 98142 BLAKE2B 21b0dabb253175ecf427a51bcc7df2de7fa3fc9fe7d9032cc378160c4c53e75efa4c0e657efc93d48bb58f786160d89cb2fd7301e3c270f73802a926c31ea378 SHA512 983bdb17b76d10eb73cf69f0ba7590806bf6786ae0c30526593ce1ab97f3b22c967f9acae83b880dd56be41a29eae9cca5726926667eb74013d0d1078433bf05
DIST publicsuffix2-2.20191221.tar.gz 99592 BLAKE2B 3e96f2b1d23a70827758eb4440892719deabdb9a67a2144fefd2d4b23e26dec0d19f6d9fd4de504d5d52c0250719ef85e929b4a2b92b7ba8896ed4055480d0d8 SHA512 d863f0937b340958ef7c8bd07d62054aead993ba31b0c2753631f2e75e48f7cea412c6501d8a94d98bf6a97a13eb0716c24a89e336787d5570e9af0386c58320
diff --git a/dev-python/publicsuffix/publicsuffix-2.20191221-r1.ebuild b/dev-python/publicsuffix/publicsuffix-2.20191221-r1.ebuild
new file mode 100644
index 000000000000..b42bc58bf1af
--- /dev/null
+++ b/dev-python/publicsuffix/publicsuffix-2.20191221-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV=release-2.2019-12-21
+
+DESCRIPTION="Get a public suffix for a domain name using the Public Suffix List."
+HOMEPAGE="https://github.com/nexB/python-publicsuffix2"
+SRC_URI="
+ https://github.com/nexB/python-publicsuffix2/archive/${MY_PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PN}2-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=dev-python/requests-2.7.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest