summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-09 10:07:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-09 10:23:19 +0200
commit284ddbe514e454ea8c74133e2b8479294a9cedd0 (patch)
tree5d0192a12f4ae19dc5d50c84451c23dd51a30786 /dev-python/pudb
parentdev-python/pudb: Port to python3.10 (diff)
downloadgentoo-284ddbe514e454ea8c74133e2b8479294a9cedd0.tar.gz
gentoo-284ddbe514e454ea8c74133e2b8479294a9cedd0.tar.bz2
gentoo-284ddbe514e454ea8c74133e2b8479294a9cedd0.zip
dev-python/pudb: Bump to 2021.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pudb')
-rw-r--r--dev-python/pudb/Manifest1
-rw-r--r--dev-python/pudb/pudb-2021.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pudb/Manifest b/dev-python/pudb/Manifest
index 6c331995a833..6901d0b9ddf3 100644
--- a/dev-python/pudb/Manifest
+++ b/dev-python/pudb/Manifest
@@ -1 +1,2 @@
DIST pudb-2020.1.tar.gz 70838 BLAKE2B c0f9ebf88851ebd859876e3e9b29239c72e308d7a544aee26baeb44a47ec3de75aed031ca10ef67c32d0262ffa690bfc063122524e64afa7d5763afb9a5baccf SHA512 4878c3f375d96130ca9a1afe668227b6f08e876e618bcffb47b1507be6bf7a393d88ab5f65f33c6497c98e645a188d5f3eaabb4f6a1e49d8d09b0f8b6b17ba14
+DIST pudb-2021.1.tar.gz 216707 BLAKE2B 1287fa48607e9b73dd0bed063b29933dd4de6ab598ad99217ab13a719a6b9654765bc44c28150962ba22703733a4e956c39e843414444c3b7fff67cefe70d7d8 SHA512 54d62f1342ab461e58a382c0eb654ecc9d3bd759844bab2f0a339e91ba805670e4dc7ccd84e8188f34e06a07ac770f1c0cddd4a4ef916885af0bdc638db81fcf
diff --git a/dev-python/pudb/pudb-2021.1.ebuild b/dev-python/pudb/pudb-2021.1.ebuild
new file mode 100644
index 000000000000..85b6a8ab92ca
--- /dev/null
+++ b/dev-python/pudb/pudb-2021.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="A full-screen, console-based Python debugger"
+HOMEPAGE="https://pypi.org/project/pudb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest