summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 08:27:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 09:13:31 +0200
commit1232155dda62b695c6259d7df86a64a4db880993 (patch)
tree40fa1c1e648da3a595c1473f92c0529e2034296e /dev-python/puremagic
parentdev-python/jsonpickle: Bump to 2.2.0 (diff)
downloadgentoo-1232155dda62b695c6259d7df86a64a4db880993.tar.gz
gentoo-1232155dda62b695c6259d7df86a64a4db880993.tar.bz2
gentoo-1232155dda62b695c6259d7df86a64a4db880993.zip
dev-python/puremagic: Bump to 1.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/puremagic')
-rw-r--r--dev-python/puremagic/Manifest1
-rw-r--r--dev-python/puremagic/puremagic-1.13.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/puremagic/Manifest b/dev-python/puremagic/Manifest
index 8bc3572c0e31..646bf60e86db 100644
--- a/dev-python/puremagic/Manifest
+++ b/dev-python/puremagic/Manifest
@@ -1,2 +1,3 @@
DIST puremagic-1.11.tar.gz 295026 BLAKE2B 4d210807d9f5eb0c2eb88b0c18aa5cdf56170b347de4f95b92c08492d5f038759b39c1aa2d6ed4bc91e96e036e6f4d0891449af8aee3beac65c4d692fa295ec0 SHA512 4d4c9a93cd56a02aefb7090c92b41048f33923bef14022158f39c39ac93326b7180b8cc97495ad5ed3eec7d9f1379a5508829ee779aaba9b8aa8f975e787b1f5
DIST puremagic-1.12.tar.gz 296831 BLAKE2B cd9979fba1016b1c4cbdd9ef1402d11dbe2faf37767e3232cf400b798cce328d90d224765cc2bf39fd0988abdfe39d1527dd7aa6e31b4737d00c1578f1cc3101 SHA512 b50e22b7597f206e8d6dbc0e2c120af21a7246568f059c6145e45471eedf04c797a9f00864468d5e05c9536f49f7fc6c7b30a83e67bf248e10ebaf8300726fde
+DIST puremagic-1.13.gh.tar.gz 300110 BLAKE2B d436735126d465cd43bc5537b2fb9385297d626b19b5b881c63fc7f3559600c9318c7ad91955cf66df2962ad122d2b42919bdee4460bc16ddb7750d4ffdc2fa2 SHA512 495777751874d4f2213b8bedb4bc3b2cdfdcacc5a1dd7cad85545fce473b8beca9a38fbe513d26c37455686265482b8bde7024111e76501d489aee7e5750d97f
diff --git a/dev-python/puremagic/puremagic-1.13.ebuild b/dev-python/puremagic/puremagic-1.13.ebuild
new file mode 100644
index 000000000000..867d39b423df
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="
+ https://github.com/cdgriffith/puremagic/
+ https://pypi.org/project/puremagic/
+"
+SRC_URI="
+ https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest