summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-17 08:55:46 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-17 09:57:11 +0100
commit8345c82f2a02149f43c3f014b5b3fbbf71317738 (patch)
treea45beb7024b4713d4dc04958ebcc3c84076f5941 /dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild
parentdev-java/laf-plugin: Clean up old. (diff)
downloadgentoo-8345c82f2a02149f43c3f014b5b3fbbf71317738.tar.gz
gentoo-8345c82f2a02149f43c3f014b5b3fbbf71317738.tar.bz2
gentoo-8345c82f2a02149f43c3f014b5b3fbbf71317738.zip
dev-python/py-cpuinfo: New package, ebuild written by me
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild')
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild
new file mode 100644
index 000000000000..0cc1f2a9db8e
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="https://github.com/workhorsy/py-cpuinfo http://pypi.python.org/pypi/py-cpuinfo"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# https://github.com/workhorsy/py-cpuinfo/issues/32
+RESTRICT="test"
+
+python_test() {
+ "${PYTHON}" test_suite.py || die
+}