summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-08-28 19:49:43 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-13 23:21:35 +0200
commit90dca8fcf123ea66f106c3d23e113ee092166c65 (patch)
tree61b1f214d458cf5a7efcb6e13eb324a31efedcc2 /dev-python/py-cpuinfo/py-cpuinfo-7.0.0.ebuild
parentnet-libs/libwebsockets: set LWS_DBUS_INCLUDE2 (diff)
downloadgentoo-90dca8fcf123ea66f106c3d23e113ee092166c65.tar.gz
gentoo-90dca8fcf123ea66f106c3d23e113ee092166c65.tar.bz2
gentoo-90dca8fcf123ea66f106c3d23e113ee092166c65.zip
dev-python/py-cpuinfo: bump to 7.0.0, add Python 3.9 support
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17302 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/py-cpuinfo/py-cpuinfo-7.0.0.ebuild')
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-7.0.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-7.0.0.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-7.0.0.ebuild
new file mode 100644
index 000000000000..2a9d661c1c18
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-7.0.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="https://github.com/workhorsy/py-cpuinfo https://pypi.org/project/py-cpuinfo/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests setup.py