summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 15:37:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 16:30:55 +0200
commit7e8c85ded5c63f4fc99a844e64dd8abe0acbe9f4 (patch)
tree3f8f6da96ec0bad5f734208ba2d7ef017eb4ea54 /dev-python/py/py-1.9.0.ebuild
parentdev-python/iniconfig: New dep of dev-python/pytest (diff)
downloadgentoo-7e8c85ded5c63f4fc99a844e64dd8abe0acbe9f4.tar.gz
gentoo-7e8c85ded5c63f4fc99a844e64dd8abe0acbe9f4.tar.bz2
gentoo-7e8c85ded5c63f4fc99a844e64dd8abe0acbe9f4.zip
dev-python/py: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/py/py-1.9.0.ebuild')
-rw-r--r--dev-python/py/py-1.9.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/py/py-1.9.0.ebuild b/dev-python/py/py-1.9.0.ebuild
new file mode 100644
index 000000000000..958ce68bf629
--- /dev/null
+++ b/dev-python/py/py-1.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="https://pylib.readthedocs.io/en/latest/ https://pypi.org/project/py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.2-skip-apiwarn-pytest31.patch
+ "${FILESDIR}"/${PN}-1.8.0-pytest-4.patch
+)
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+src_prepare() {
+ # broken on py3.8, don't seem important
+ sed -i -e 's:test_syntaxerror_rerepresentation:_&:' \
+ -e 's:test_comments:_&:' \
+ testing/code/test_source.py || die
+ # broken on py3.9, this package is just dead
+ sed -i -e 's:test_getfslineno:_&:' \
+ testing/code/test_source.py || die
+
+ distutils-r1_src_prepare
+
+ # broken, and relying on exact assertion strings
+ rm testing/code/test_assertion.py || die
+}