summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 02:54:48 +0100
committerSam James <sam@gentoo.org>2022-05-31 02:56:46 +0100
commitd086e3bda928fd1298ecf16b75a54c7480acef53 (patch)
tree7665a9be1ab7e93d8c47f2fffa3312132870640b /dev-python/pyacoustid/pyacoustid-1.2.2.ebuild
parentdev-python/python-ly: add 0.9.7 (diff)
downloadgentoo-d086e3bda928fd1298ecf16b75a54c7480acef53.tar.gz
gentoo-d086e3bda928fd1298ecf16b75a54c7480acef53.tar.bz2
gentoo-d086e3bda928fd1298ecf16b75a54c7480acef53.zip
dev-python/pyacoustid: add 1.2.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyacoustid/pyacoustid-1.2.2.ebuild')
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyacoustid/pyacoustid-1.2.2.ebuild b/dev-python/pyacoustid/pyacoustid-1.2.2.ebuild
new file mode 100644
index 000000000000..5428e169fb59
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Chromaprint and the AcoustID web service"
+HOMEPAGE="https://pypi.org/project/pyacoustid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/audioread[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ media-libs/chromaprint
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc aidmatch.py fpcalc.py
+ docompress -x /usr/share/doc/${PF}/examples/
+ fi
+}