summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-30 09:02:49 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-30 09:24:42 +0200
commit16f81a1eb681e39805fc4b2bff9713a95e8cede0 (patch)
tree813b115bdfa1a532ae9d36d0e9c6081dbefbeec9 /dev-python/pyaes/pyaes-1.6.1-r1.ebuild
parentdev-python/pyaes: Fix running all tests (diff)
downloadgentoo-16f81a1eb681e39805fc4b2bff9713a95e8cede0.tar.gz
gentoo-16f81a1eb681e39805fc4b2bff9713a95e8cede0.tar.bz2
gentoo-16f81a1eb681e39805fc4b2bff9713a95e8cede0.zip
dev-python/pyaes: Remove unused dep on setuptools
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyaes/pyaes-1.6.1-r1.ebuild')
-rw-r--r--dev-python/pyaes/pyaes-1.6.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyaes/pyaes-1.6.1-r1.ebuild b/dev-python/pyaes/pyaes-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..28e71ec67c0c
--- /dev/null
+++ b/dev-python/pyaes/pyaes-1.6.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+HOMEPAGE="https://pypi.org/project/pyaes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+python_test() {
+ local t fail=
+ for t in tests/test-*.py; do
+ einfo "${t}"
+ "${EPYTHON}" "${t}" || fail=1
+ done
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}