summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-16 13:06:30 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-16 13:06:43 -0700
commitdbd1785f2d4aecca22c5b9512e8f852021a67353 (patch)
tree19a32b90155e8f2fbdf7f0f04a0fde928fd98990 /dev-python/pyaes
parentprofiles/alpha: Drop unnecessary package.use.masks (diff)
downloadgentoo-dbd1785f2d4aecca22c5b9512e8f852021a67353.tar.gz
gentoo-dbd1785f2d4aecca22c5b9512e8f852021a67353.tar.bz2
gentoo-dbd1785f2d4aecca22c5b9512e8f852021a67353.zip
dev-python/pyaes: Add missing test dependency
Closes: https://bugs.gentoo.org/651262 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/pyaes')
-rw-r--r--dev-python/pyaes/pyaes-1.6.1-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyaes/pyaes-1.6.1-r2.ebuild b/dev-python/pyaes/pyaes-1.6.1-r2.ebuild
new file mode 100644
index 000000000000..2c3a31013a35
--- /dev/null
+++ b/dev-python/pyaes/pyaes-1.6.1-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+HOMEPAGE="https://pypi.org/project/pyaes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/pycryptodome[${PYTHON_USEDEP}] )"
+
+python_test() {
+ local t fail=
+ for t in tests/test-*.py; do
+ einfo "${t}"
+ "${EPYTHON}" "${t}" || fail=1
+ done
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}