summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-17 14:13:48 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-17 14:14:54 +0200
commit21c069e73fc558f53dabed7a2faef2aaa2909c39 (patch)
tree8c454f6412e55097a8a0797f9cf11f774255fa7c /dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
parentdev-python/python-ptrace: Tested on py3.6 (diff)
downloadgentoo-21c069e73fc558f53dabed7a2faef2aaa2909c39.tar.gz
gentoo-21c069e73fc558f53dabed7a2faef2aaa2909c39.tar.bz2
gentoo-21c069e73fc558f53dabed7a2faef2aaa2909c39.zip
dev-python/pyalsaaudio: Include code for running tests
Diffstat (limited to 'dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild')
-rw-r--r--dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild b/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
index 74e394c49f63..5470b7f46c42 100644
--- a/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
+++ b/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -31,6 +31,10 @@ python_compile() {
distutils-r1_python_compile
}
+python_test() {
+ "${PYTHON}" test.py -v || die "Tests fail with ${EPYTHON}"
+}
+
python_install_all() {
use doc && local HTML_DOCS=( doc/html/. )
local EXAMPLES=( *test.py )