summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-18 18:48:22 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-18 20:10:53 +0000
commit5949099c9a3807431bda3b16b9d571bd4fda4bfc (patch)
treed558d17682192e2f0b322264d58c15d33d8df3ad /dev-python/pyamg/pyamg-3.0.2.ebuild
parentdev-python/partd: cleanup dependencies (diff)
downloadgentoo-5949099c9a3807431bda3b16b9d571bd4fda4bfc.tar.gz
gentoo-5949099c9a3807431bda3b16b9d571bd4fda4bfc.tar.bz2
gentoo-5949099c9a3807431bda3b16b9d571bd4fda4bfc.zip
dev-python/pyamg: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/pyamg/pyamg-3.0.2.ebuild')
-rw-r--r--dev-python/pyamg/pyamg-3.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyamg/pyamg-3.0.2.ebuild b/dev-python/pyamg/pyamg-3.0.2.ebuild
new file mode 100644
index 000000000000..357e370ad6cd
--- /dev/null
+++ b/dev-python/pyamg/pyamg-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="http://pyamg.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${T}" || die # need to be away source directory
+ nosetests --verbose pyamg || die
+}