summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-06 16:12:15 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-06 17:22:23 +0100
commit64cbbe6b36a8693d5af93af00732318bfe0b6c25 (patch)
tree98ef6e10cff3cf1e540d3c4b181c5c173d06a292 /dev-python/pyamg
parentsci-libs/scikits_learn: Version Bump (diff)
downloadgentoo-64cbbe6b36a8693d5af93af00732318bfe0b6c25.tar.gz
gentoo-64cbbe6b36a8693d5af93af00732318bfe0b6c25.tar.bz2
gentoo-64cbbe6b36a8693d5af93af00732318bfe0b6c25.zip
dev-python/pyamg: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyamg')
-rw-r--r--dev-python/pyamg/Manifest1
-rw-r--r--dev-python/pyamg/metadata.xml10
-rw-r--r--dev-python/pyamg/pyamg-2.2.1.ebuild32
3 files changed, 38 insertions, 5 deletions
diff --git a/dev-python/pyamg/Manifest b/dev-python/pyamg/Manifest
index 6bf901647e5c..dc935f63bc4e 100644
--- a/dev-python/pyamg/Manifest
+++ b/dev-python/pyamg/Manifest
@@ -1 +1,2 @@
DIST pyamg-2.1.0.tar.gz 752632 SHA256 060a32ea8805b8e49e6d7304ab771efccd34d5e363a65f4f2cb33d85981225de SHA512 d2574ccb093e6c5bd214c4366ec70bfeae73449f98932a9a4435afb2d606b12a4d479411a88bcac4df500e33dbf635ae981620c584e688abc3f2cca6c6188d4d WHIRLPOOL ccf0817561eae43bb859aaedc9c7b4c94e338a2fc6817467bb5f162df3e63720030d3e36d55e72e9f7e613aab89cf4211f9c20fc97d566e3d7cdec988c9d9f6f
+DIST pyamg-2.2.1.tar.gz 753299 SHA256 e15d91b7650e24e9c70c21483244d59e42cdcb64bb8d6474c4cbd0ecca8d3b8f SHA512 b784626fbdfcfa338560763a38bc5ddde07ace5213225d4c876b09be93019e81e641630e88952aab20a6c4f859bf6260730459d247c35d531433df4ecd209248 WHIRLPOOL f48d131f86eae4b7f15abce84044767afc08708a1ad58b38f1af87278d7ecde7913abd3c17a81f1dcd14d0320d673598d89346303b98312f01c14906368e4b35
diff --git a/dev-python/pyamg/metadata.xml b/dev-python/pyamg/metadata.xml
index 106c66bc219b..66a753f3fbd2 100644
--- a/dev-python/pyamg/metadata.xml
+++ b/dev-python/pyamg/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
PyAMG is a library of Algebraic Multigrid (AMG) solvers with a
Python interface.
The predominant portion of PyAMG is written in Python with a smaller
amount of supporting C++ code for performance critical operations.
</longdescription>
-<upstream>
- <remote-id type="pypi">pyamg</remote-id>
-</upstream>
+ <upstream>
+ <remote-id type="pypi">pyamg</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/pyamg/pyamg-2.2.1.ebuild b/dev-python/pyamg/pyamg-2.2.1.ebuild
new file mode 100644
index 000000000000..bcfdd108f5ea
--- /dev/null
+++ b/dev-python/pyamg/pyamg-2.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="http://pyamg.github.io/ https://github.com/pyamg/pyamg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${T}" || die # need to be away source directory
+ "${PYTHON}" "${S}"/test_pyamg_install.py || die
+}