summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-05 06:54:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-05 06:55:43 +0200
commit766160dc181362ca28411b72128a78a20303c709 (patch)
tree13ca9a7eaa4f46d094f5c4df3378246c734116ec /dev-python/pyaml/pyaml-23.5.6.ebuild
parentRename dev-pyton/{pretty-yaml → pyaml} (diff)
downloadgentoo-766160dc181362ca28411b72128a78a20303c709.tar.gz
gentoo-766160dc181362ca28411b72128a78a20303c709.tar.bz2
gentoo-766160dc181362ca28411b72128a78a20303c709.zip
dev-python/pyaml: Bump to 23.5.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyaml/pyaml-23.5.6.ebuild')
-rw-r--r--dev-python/pyaml/pyaml-23.5.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyaml/pyaml-23.5.6.ebuild b/dev-python/pyaml/pyaml-23.5.6.ebuild
new file mode 100644
index 000000000000..cf3738ac27a8
--- /dev/null
+++ b/dev-python/pyaml/pyaml-23.5.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="
+ https://github.com/mk-fg/pretty-yaml/
+ https://pypi.org/project/pyaml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest