summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-13 16:58:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-13 17:02:00 +0200
commit63233db9f5e42746b86512c83e9dd60c632d4b85 (patch)
tree3e8da805aff46b3a78f185b3255edf36406775d3 /dev-python/pyaml/pyaml-23.9.6.ebuild
parentdev-python/ipywidgets: Bump to 8.1.1 (diff)
downloadgentoo-63233db9f5e42746b86512c83e9dd60c632d4b85.tar.gz
gentoo-63233db9f5e42746b86512c83e9dd60c632d4b85.tar.bz2
gentoo-63233db9f5e42746b86512c83e9dd60c632d4b85.zip
dev-python/pyaml: Bump to 23.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyaml/pyaml-23.9.6.ebuild')
-rw-r--r--dev-python/pyaml/pyaml-23.9.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyaml/pyaml-23.9.6.ebuild b/dev-python/pyaml/pyaml-23.9.6.ebuild
new file mode 100644
index 000000000000..a49398baeb97
--- /dev/null
+++ b/dev-python/pyaml/pyaml-23.9.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="
+ https://github.com/mk-fg/pretty-yaml/
+ https://pypi.org/project/pyaml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest