summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-13 21:54:14 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-13 21:56:39 +0200
commit960fed3e8ecd6f7aa174ea8e723a2f0461f9120a (patch)
treeec5a65c661fcbe520e767dc4b27ba991ebbff490 /dev-python/pyasn1-modules/pyasn1-modules-0.2.8.ebuild
parentx11-libs/libvdpau: Update SRC_URI/A (diff)
downloadgentoo-960fed3e8ecd6f7aa174ea8e723a2f0461f9120a.tar.gz
gentoo-960fed3e8ecd6f7aa174ea8e723a2f0461f9120a.tar.bz2
gentoo-960fed3e8ecd6f7aa174ea8e723a2f0461f9120a.zip
dev-python/pyasn1-modules: 0.2.8 + EAPI 7
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'dev-python/pyasn1-modules/pyasn1-modules-0.2.8.ebuild')
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.2.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.2.8.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.2.8.ebuild
new file mode 100644
index 000000000000..1b49331e3afb
--- /dev/null
+++ b/dev-python/pyasn1-modules/pyasn1-modules-0.2.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pyasn1 modules"
+HOMEPAGE="http://snmplabs.com/pyasn1/ https://github.com/etingof/pyasn1-modules/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/pyasn1-0.4.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${P}
+ doins -r tools
+}