summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-29 11:41:36 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-01 16:43:04 -0400
commit7cfac948c05bc1cc97272293d637de2be8692344 (patch)
tree7e59674dcd99f8f5cc8ffb70defc4776f1db8b46 /dev-python/pybind11
parentdev-python/pluginbase: bump + py3.8 (diff)
downloadgentoo-7cfac948c05bc1cc97272293d637de2be8692344.tar.gz
gentoo-7cfac948c05bc1cc97272293d637de2be8692344.tar.bz2
gentoo-7cfac948c05bc1cc97272293d637de2be8692344.zip
dev-python/pybind11: bump
fix bug #706070 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.5.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 5ff276e9ad32..04715a0032b3 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1 +1,2 @@
DIST pybind11-2.4.3.tar.gz 138789 BLAKE2B 6279ddbc4ca4c8a62eeff684cac789a315eef0ce769258c8152f7073f8bbea39e582ed1ea86fae6878f46c675ed998c314bbaa54a40457287833cc555f5d9692 SHA512 97b6ffb38dbda8021e8265c2052df65785d532dbcd94a2b711306f806eab1a9e2aaf31ea466f13eb5784856ac69e0f4c1dc6d742aa70e5a10ce9ce338e5e9d84
+DIST pybind11-2.5.0.tar.gz 573769 BLAKE2B e46d99f873f8266efc577d3e0ab1e8a78784a45c35995bc3486501d627698e0fb10205008e8cb82c84e971f20cd02a6d2f08390f3a3041fff1a21c45f11b197f SHA512 7f3a9c71916749436898d1844ef6b112baf0817a386308b5df8dec2a912ef4b6a932b94965e98f227c49fa77312f131972a6039f23b84a3daf6442a8ab0be7c2
diff --git a/dev-python/pybind11/pybind11-2.5.0.ebuild b/dev-python/pybind11/pybind11-2.5.0.ebuild
new file mode 100644
index 000000000000..9f4ad379f84e
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.5.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
+SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ doc? (
+ dev-python/breathe[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-cpp/eigen:3
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( README.md CONTRIBUTING.md ISSUE_TEMPLATE.md )
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python3_6' )
+}
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ local mycmakeargs=(
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=OFF
+ )
+
+ cmake_src_configure
+}
+
+python_compile_all() {
+ # No compilation has to be done by cmake
+
+ # documentation is not covered by cmake, but has it's own makefile
+ # using sphinx
+ if use doc; then
+ python_setup 'python3_6'
+ pushd "${S}"/docs || die
+ emake info man html
+ popd || die
+ fi
+}
+
+python_install_all() {
+ cmake_src_install
+ if use doc; then
+ python_setup
+ local HTML_DOCS=( "${S}"/docs/.build/html/. )
+
+ # install man and info pages
+ doman "${S}"/docs/.build/man/pybind11.1
+ doinfo "${S}"/docs/.build/texinfo/pybind11.info
+ fi
+
+ distutils-r1_python_install_all
+}