summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Pettersson <william@ewpettersson.se>2020-06-02 11:16:23 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-06-28 13:40:56 +0300
commiteb8763891423f6126d735fa6eb57f2b31881f403 (patch)
tree82619fa33d37bd0878b7cf3f66e6d94a3e52bde3 /dev-python/pybtex/pybtex-0.22.2.ebuild
parentdev-python/latexcodec: new package (diff)
downloadgentoo-eb8763891423f6126d735fa6eb57f2b31881f403.tar.gz
gentoo-eb8763891423f6126d735fa6eb57f2b31881f403.tar.bz2
gentoo-eb8763891423f6126d735fa6eb57f2b31881f403.zip
dev-python/pybtex: New package
BibTeX-compatible bibliography processor Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --force Signed-off-by: William Pettersson <william@ewpettersson.se> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pybtex/pybtex-0.22.2.ebuild')
-rw-r--r--dev-python/pybtex/pybtex-0.22.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pybtex/pybtex-0.22.2.ebuild b/dev-python/pybtex/pybtex-0.22.2.ebuild
new file mode 100644
index 000000000000..b5b454d8561d
--- /dev/null
+++ b/dev-python/pybtex/pybtex-0.22.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="BibTeX-compatible bibliography processor"
+HOMEPAGE="https://pybtex.org https://pypi.org/project/pybtex/"
+SRC_URI="https://files.pythonhosted.org/packages/source/p/${PN}/${P}.tar.gz"
+PATCHES=( "${FILESDIR}/${P}-fix-test-installation.patch" )
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/latexcodec[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+BDEPEND="test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest