summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-03 23:54:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-04 00:01:16 +0200
commitf6a6f101e7713ac8d8e659f10d51dc0f3934ba43 (patch)
tree0cce024c623db216b4b6a56c0bd23f1b084369d9 /dev-python/pycairo
parentdev-util/stripe-mock: Bump to 0.106.0 (diff)
downloadgentoo-f6a6f101e7713ac8d8e659f10d51dc0f3934ba43.tar.gz
gentoo-f6a6f101e7713ac8d8e659f10d51dc0f3934ba43.tar.bz2
gentoo-f6a6f101e7713ac8d8e659f10d51dc0f3934ba43.zip
dev-python/pycairo: Bump to 1.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/Manifest1
-rw-r--r--dev-python/pycairo/pycairo-1.20.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index 567b04530540..baf457c5c371 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1 +1,2 @@
DIST pycairo-1.20.0.tar.gz 344370 BLAKE2B b72a3dfd3ad6332f6be2c0fc0650ef87d97a51881bd239421cdb6355016e952093f9fa05b7872d7cce4a50bc4bac27ff0fb4c11e446e51ada9d7c1adc019a175 SHA512 d32d008b741653d02324b206a438f5fd85f2a433201d6f8b98c8f1adc712abea611a4b5ed95c55258efb662dc579eed6b2f752b10d9fc2b6a7c8e5edd19e5266
+DIST pycairo-1.20.1.tar.gz 344639 BLAKE2B 7327a1b9aacc62eb7b2630ac2b9ce43ad7a44e60cb749b60a2973fb9036a84c1f3f4264da428d720158a5e32cd47f679d5956ebf3ce094e75d742584a68adda4 SHA512 bb2340170c1d39d50dd8ceeb1b6ceadd96ddbd27d78a8a5b7dadf7dc427558d766f65d62e1ceeae19ab200e7ffb5ad122b5e51daa8ef9bff08fcd97a44005697
diff --git a/dev-python/pycairo/pycairo-1.20.1.ebuild b/dev-python/pycairo/pycairo-1.20.1.ebuild
new file mode 100644
index 000000000000..1e68e62256d3
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.20.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
+SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=x11-libs/cairo-1.15.10[svg]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests setup.py
+
+python_install() {
+ distutils-r1_python_install \
+ install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}