summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 14:57:39 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 15:36:22 +0200
commitc19f041fc0c78ab39d5b9d73a02c667b53baf4d1 (patch)
tree0a336d0f373ba8425b7332f3b23e126cc59034a2 /dev-python/pycares/pycares-2.4.0.ebuild
parentnet-irc/irssi: amd64 stable wrt bug #688944 (diff)
downloadgentoo-c19f041fc0c78ab39d5b9d73a02c667b53baf4d1.tar.gz
gentoo-c19f041fc0c78ab39d5b9d73a02c667b53baf4d1.tar.bz2
gentoo-c19f041fc0c78ab39d5b9d73a02c667b53baf4d1.zip
dev-python/pycares: Bump to 2.4.0, py3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycares/pycares-2.4.0.ebuild')
-rw-r--r--dev-python/pycares/pycares-2.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pycares/pycares-2.4.0.ebuild b/dev-python/pycares/pycares-2.4.0.ebuild
new file mode 100644
index 000000000000..63fae6d646f7
--- /dev/null
+++ b/dev-python/pycares/pycares-2.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+# uses bundled/patched c-ares
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}