summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-14 09:34:17 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-14 09:44:03 +0100
commit761030f9038f3764660fdbc7bfe7a29fbfdf8b06 (patch)
tree7b20abb10fca2583bfcb219be861ae1618e5f22a /dev-python/pycares/pycares-3.1.0_p3.ebuild
parentdev-util/lldb: Update one more CMake var (diff)
downloadgentoo-761030f9038f3764660fdbc7bfe7a29fbfdf8b06.tar.gz
gentoo-761030f9038f3764660fdbc7bfe7a29fbfdf8b06.tar.bz2
gentoo-761030f9038f3764660fdbc7bfe7a29fbfdf8b06.zip
dev-python/pycares: Bump to 1.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycares/pycares-3.1.0_p3.ebuild')
-rw-r--r--dev-python/pycares/pycares-3.1.0_p3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycares/pycares-3.1.0_p3.ebuild b/dev-python/pycares/pycares-3.1.0_p3.ebuild
new file mode 100644
index 000000000000..40e86c064a53
--- /dev/null
+++ b/dev-python/pycares/pycares-3.1.0_p3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="https://github.com/saghul/pycares/archive/${P/_p/-fix}.tar.gz"
+S=${WORKDIR}/${PN}-${P/_p/-fix}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+# uses bundled/patched c-ares
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}