summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pychecker/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pychecker/files')
-rw-r--r--dev-python/pychecker/files/pychecker-0.8.17-no-data-files.patch15
-rw-r--r--dev-python/pychecker/files/pychecker-0.8.18-pychecker2.patch11
-rw-r--r--dev-python/pychecker/files/pychecker-0.8.19-create_script.patch13
-rw-r--r--dev-python/pychecker/files/pychecker-0.8.19-version.patch12
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pychecker/files/pychecker-0.8.17-no-data-files.patch b/dev-python/pychecker/files/pychecker-0.8.17-no-data-files.patch
new file mode 100644
index 000000000000..aeaaa1a98443
--- /dev/null
+++ b/dev-python/pychecker/files/pychecker-0.8.17-no-data-files.patch
@@ -0,0 +1,15 @@
+=== modified file 'setup.py'
+--- setup.py 2008-09-01 16:31:56 +0000
++++ setup.py 2008-09-01 16:33:28 +0000
+@@ -255,7 +255,9 @@
+ 'url' : "http://pychecker.sourceforge.net/",
+ 'packages' : [ 'pychecker', ],
+ 'scripts' : [ "pychecker" ], # note: will be replaced by customized action
+- 'data_files' : [ ( "pychecker", DATA_FILES, ) ],
++ # Gentoo Modification: Do not install data files into site-packages
++ # use DOCS variable in ebuild instead
++ #'data_files' : [ ( "pychecker", DATA_FILES, ) ],
+ 'long_description' : LONG_DESCRIPTION,
+ 'cmdclass' : CUSTOMIZED_ACTIONS,
+ }
+
diff --git a/dev-python/pychecker/files/pychecker-0.8.18-pychecker2.patch b/dev-python/pychecker/files/pychecker-0.8.18-pychecker2.patch
new file mode 100644
index 000000000000..e225d1a06b14
--- /dev/null
+++ b/dev-python/pychecker/files/pychecker-0.8.18-pychecker2.patch
@@ -0,0 +1,11 @@
+--- setup.py 2008-11-09 17:43:10.928105449 +0100
++++ setup.py 2008-11-09 17:38:52.000000000 +0100
+@@ -258,7 +258,7 @@
+ 'author' : "Neal Norwitz",
+ 'author_email' : "nnorwitz@gmail.com",
+ 'url' : "http://pychecker.sourceforge.net/",
+- 'packages' : [ 'pychecker', ],
++ 'packages' : [ 'pychecker', 'pychecker2' ],
+ 'scripts' : [ "pychecker" ], # note: will be replaced by customized action
+ # Gentoo Modification: Do not install data files into site-packages
+ # use DOCS variable in ebuild instead
diff --git a/dev-python/pychecker/files/pychecker-0.8.19-create_script.patch b/dev-python/pychecker/files/pychecker-0.8.19-create_script.patch
new file mode 100644
index 000000000000..ca4367591174
--- /dev/null
+++ b/dev-python/pychecker/files/pychecker-0.8.19-create_script.patch
@@ -0,0 +1,13 @@
+--- setup.py
++++ setup.py
+@@ -221,7 +221,9 @@
+ script_str = "%s %s %%*\n" % (sys.executable, checker_path)
+ else:
+ script_str = '#! /bin/sh\n\n%s %s "$@"\n' % (sys.executable, checker_path)
+- open(script_path, "w").write(script_str)
++ script = open(script_path, "w")
++ script.write(script_str)
++ script.close()
+ except Exception, e:
+ print "ERROR: Unable to create %s: %s" % (script_path, e)
+ raise e
diff --git a/dev-python/pychecker/files/pychecker-0.8.19-version.patch b/dev-python/pychecker/files/pychecker-0.8.19-version.patch
new file mode 100644
index 000000000000..9fe8490175a8
--- /dev/null
+++ b/dev-python/pychecker/files/pychecker-0.8.19-version.patch
@@ -0,0 +1,12 @@
+diff -ur pychecker-0.8.19.orig/pychecker/Config.py pychecker-0.8.19/pychecker/Config.py
+--- pychecker/Config.py 2013-02-01 12:06:10.669695876 +0800
++++ pychecker/Config.py 2013-02-01 12:06:26.238695001 +0800
+@@ -33,7 +33,7 @@
+
+ _RC_FILE = ".pycheckrc"
+ CHECKER_VAR = '__pychecker__'
+-_VERSION = '0.8.18'
++_VERSION = '0.8.19'
+
+ _DEFAULT_BLACK_LIST = [ "Tkinter", "wxPython", "gtk", "GTK", "GDK", ]
+ _DEFAULT_VARIABLE_IGNORE_LIST = [ '__version__', '__warningregistry__',