summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-13 07:56:58 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-13 08:19:17 +0100
commit71f4d670cde1dd13173f61a223057b28cc23a0be (patch)
tree45394d4810efa737e11abc442b057af531d2f7f3 /dev-python/pychm/pychm-0.8.6.ebuild
parentdev-util/lldb: Update upstream CMake var names (diff)
downloadgentoo-71f4d670cde1dd13173f61a223057b28cc23a0be.tar.gz
gentoo-71f4d670cde1dd13173f61a223057b28cc23a0be.tar.bz2
gentoo-71f4d670cde1dd13173f61a223057b28cc23a0be.zip
dev-python/pychm: Bump to 0.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pychm/pychm-0.8.6.ebuild')
-rw-r--r--dev-python/pychm/pychm-0.8.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pychm/pychm-0.8.6.ebuild b/dev-python/pychm/pychm-0.8.6.ebuild
new file mode 100644
index 000000000000..5d77dcd07ccc
--- /dev/null
+++ b/dev-python/pychm/pychm-0.8.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the chmlib library"
+HOMEPAGE="https://github.com/dottedmag/pychm"
+SRC_URI="https://github.com/dottedmag/pychm/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-libs/chmlib"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest