summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-22 17:52:33 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-22 18:00:47 -0400
commit10be7674d7f7a259ac70c1462d1697e8a4f2db9b (patch)
tree31c10ca4a6b2c345ccc36f46e4fac84db7a1dbd4 /dev-python/pychroot/pychroot-9999.ebuild
parentdev-python/snakeoil: version bump to 0.7.2 (diff)
downloadgentoo-10be7674d7f7a259ac70c1462d1697e8a4f2db9b.tar.gz
gentoo-10be7674d7f7a259ac70c1462d1697e8a4f2db9b.tar.bz2
gentoo-10be7674d7f7a259ac70c1462d1697e8a4f2db9b.zip
dev-python/pychroot: version bump to 0.9.17
Diffstat (limited to 'dev-python/pychroot/pychroot-9999.ebuild')
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 9809bcd783a7..fe3de49275b7 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/pkgcore/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi
DESCRIPTION="a python library and cli tool that simplify chroot handling"
@@ -20,9 +20,12 @@ LICENSE="BSD"
SLOT="0"
IUSE="test"
-RDEPEND="
- =dev-python/snakeoil-9999[${PYTHON_USEDEP}]
-"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.7.2[${PYTHON_USEDEP}]"
+fi
+
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (