summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-10-25 01:19:54 -0600
committerTim Harder <radhermit@gentoo.org>2020-10-25 01:23:05 -0600
commit52e234c788a1e5ea90b279729fb0514f44528778 (patch)
treefc7564e75269cad57e12cce47a650e5f2b4bdccc /dev-python/pychroot
parentmedia-libs/exiftool: remove old (diff)
downloadgentoo-52e234c788a1e5ea90b279729fb0514f44528778.tar.gz
gentoo-52e234c788a1e5ea90b279729fb0514f44528778.tar.bz2
gentoo-52e234c788a1e5ea90b279729fb0514f44528778.zip
dev-python/pychroot: version bump to 0.10.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/Manifest1
-rw-r--r--dev-python/pychroot/pychroot-0.10.2.ebuild44
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild4
3 files changed, 47 insertions, 2 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index 77041c227436..ab3f20f73069 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1 +1,2 @@
DIST pychroot-0.10.1.tar.gz 22169 BLAKE2B 7c39438addfbf9d307ebc751585c8add24712b0a3917986dd76478932389c39b8fbc6238cb21e4c1d13fee08f9478365911e766b676176fe209b4341c551267a SHA512 4df7f405872b693bf9ecac331927f749653b7251a49eaa10c423357f3150bbcbea73052ec4363a0f510aaeecd6b467d985402a8f764e99e67f5882e6b2ea4f97
+DIST pychroot-0.10.2.tar.gz 23477 BLAKE2B a5145908c565479ba05583e396c669d344193dacaa70b489b152b49cc092cf5f77193324d48917271d01ce67c06ae737815d5c3098d02bc9ed5f1c25c2dca0f9 SHA512 e5ed1b94dc0779890786bb381fba86d13fbcdbc3df411cfcafc868ebb62fe94cf1248d15a20902b4df5dc4420abc0a93fccc7ddcb2f42ad7244a657b5ec99c76
diff --git a/dev-python/pychroot/pychroot-0.10.2.ebuild b/dev-python/pychroot/pychroot-0.10.2.ebuild
new file mode 100644
index 000000000000..61c910718795
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.10.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.8.4[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 218709a73ba5..61c910718795 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then