summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-30 23:13:28 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-30 23:13:28 -0700
commita98c96d1bfb89a5e2f07318f0c994a0fc039be4e (patch)
tree249c7efa078950c7149a70c226325fe8cc4b7386 /dev-python/pychroot
parentdev-python/snakeoil: add missing conditional test RESTRICT (diff)
downloadgentoo-a98c96d1bfb89a5e2f07318f0c994a0fc039be4e.tar.gz
gentoo-a98c96d1bfb89a5e2f07318f0c994a0fc039be4e.tar.bz2
gentoo-a98c96d1bfb89a5e2f07318f0c994a0fc039be4e.zip
dev-python/pychroot: version bump to 0.10.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/Manifest1
-rw-r--r--dev-python/pychroot/pychroot-0.10.1.ebuild53
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild13
3 files changed, 63 insertions, 4 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index 1cd4cc1350f0..a384ddf5e76a 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1,2 +1,3 @@
DIST pychroot-0.10.0.tar.gz 23960 BLAKE2B 6d22ccbf3d71854d863577f0cf5ec3b1bea40f0f80d5c07942520d5d522ee299222e96cab4893c9cab93866c7f881052f67ad9091267c329a772fc4c3065bae1 SHA512 4a3941da9a94b75963e72536ec8f6218564dbdcb97e6314562044eb55f523e0704aecbc81e8e377338781e8bfd1a2aafb22cdc82f37bdb198a03e0e30d2323e5
+DIST pychroot-0.10.1.tar.gz 22169 BLAKE2B 7c39438addfbf9d307ebc751585c8add24712b0a3917986dd76478932389c39b8fbc6238cb21e4c1d13fee08f9478365911e766b676176fe209b4341c551267a SHA512 4df7f405872b693bf9ecac331927f749653b7251a49eaa10c423357f3150bbcbea73052ec4363a0f510aaeecd6b467d985402a8f764e99e67f5882e6b2ea4f97
DIST pychroot-0.9.18.tar.gz 32879 BLAKE2B 769b3347bae3f7dfb47c0335015cc898ec851a3d45f774a4e21aeaf9b8d7937331bc69aa5bcbb298e76e7e51ffc2e55f049336fd90f6b08fc3bba87089f2205d SHA512 59c8750c9ba8d601eca485079c04d4153bba92531dbd30fba0104694e4435d76e65b762b76ef89a6a6f8908dd6054d1d95fe4be74825ac1c5a56e473370dfa41
diff --git a/dev-python/pychroot/pychroot-0.10.1.ebuild b/dev-python/pychroot/pychroot-0.10.1.ebuild
new file mode 100644
index 000000000000..4f5fc21330e9
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.10.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.8.4[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+[[ ${PV} == *9999 ]] && BDEPEND+=" $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')"
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+python_compile_all() {
+ esetup.py build_man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ esetup.py install_man --mandir="${ED}/usr/share/man"
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index e1419b49ab2e..4f5fc21330e9 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -24,14 +24,19 @@ RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]]; then
RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND=">=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
+ RDEPEND=">=dev-python/snakeoil-0.8.4[${PYTHON_USEDEP}]"
fi
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+[[ ${PV} == *9999 ]] && BDEPEND+=" $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')"
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
python_compile_all() {
esetup.py build_man