summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pycmd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pycmd')
-rw-r--r--dev-python/pycmd/Manifest2
-rw-r--r--dev-python/pycmd/metadata.xml8
-rw-r--r--dev-python/pycmd/pycmd-1.1.ebuild21
-rw-r--r--dev-python/pycmd/pycmd-1.2.ebuild23
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pycmd/Manifest b/dev-python/pycmd/Manifest
new file mode 100644
index 000000000000..c0c7f3f92267
--- /dev/null
+++ b/dev-python/pycmd/Manifest
@@ -0,0 +1,2 @@
+DIST pycmd-1.1.tar.gz 12407 SHA256 5c2879ef827a6e2605157eb74642e858bfb8873aa18335aea30524ecf20f150b SHA512 55572fb69ab9c8c614e28b2c25e9de536ac65b80c81cb713d6a48331e5952d369ce84440465ff1f67af3cad804187c7f4e103e5d28b6e2cfd9036bdc1c8bb2dd WHIRLPOOL 8ae828ce6664d1686aadc801e223d942deab51b33d141e0a3ca0983bc6e235fd97927fcc36e7e571d57b61318c3847fc35c12c70b74a7d8afedcde3c258a051c
+DIST pycmd-1.2.tar.gz 12896 SHA256 adc1976c0106919e9338db20102b91009256dcfec924a66928d7297026f72477 SHA512 a9506e59889d112a40e1ef115a919644cce31320603904b350cc0a459775dc3d7454dc3f06953b1534cebbf429942bf1577302470bc54665c8dec5eb64b97957 WHIRLPOOL 9c7e185cd96a37f5794bdb5116a6a15327e660e0291c2a4a030d157c2956384d10275907997aa6eb0f569d7b30e406df952d17f5b03a7719af35fe86443b3d7c
diff --git a/dev-python/pycmd/metadata.xml b/dev-python/pycmd/metadata.xml
new file mode 100644
index 000000000000..78a66191b6b4
--- /dev/null
+++ b/dev-python/pycmd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pycmd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycmd/pycmd-1.1.ebuild b/dev-python/pycmd/pycmd-1.1.ebuild
new file mode 100644
index 000000000000..a492d230a43d
--- /dev/null
+++ b/dev-python/pycmd/pycmd-1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="pycmd: tools for managing/searching Python related files"
+HOMEPAGE="http://pypi.python.org/pypi/pycmd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/py-1.4.9"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/pycmd/pycmd-1.2.ebuild b/dev-python/pycmd/pycmd-1.2.ebuild
new file mode 100644
index 000000000000..7ecd2ff04502
--- /dev/null
+++ b/dev-python/pycmd/pycmd-1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pycmd: tools for managing/searching Python related files"
+HOMEPAGE="http://pypi.python.org/pypi/pycmd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/py-1.4.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# Test files present however are not ready to run as they are supplied in the source
+# The source repo is not listed at all in the page @pypi.