summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2017-01-02 18:47:38 +0100
committerTobias Klausmann <klausman@gentoo.org>2017-01-02 18:47:38 +0100
commit522f3f78b9ed32912ddb4c788e698f111cc14d84 (patch)
tree52c779d832da85416b527b842d02aee0432ed17c /dev-python/pycodestyle/pycodestyle-2.2.0.ebuild
parentapp-emulation/wine: Apply flex263 patch to all available ebuilds (diff)
downloadgentoo-522f3f78b9ed32912ddb4c788e698f111cc14d84.tar.gz
gentoo-522f3f78b9ed32912ddb4c788e698f111cc14d84.tar.bz2
gentoo-522f3f78b9ed32912ddb4c788e698f111cc14d84.zip
dev-python/pycodestyle: Bump to 2.2.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pycodestyle/pycodestyle-2.2.0.ebuild')
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/pycodestyle-2.2.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.2.0.ebuild
new file mode 100644
index 000000000000..c1734c22d24e
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="https://pypi.python.org/pypi/pycodestyle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --testsuite=testsuite || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}