summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2021-09-10 13:27:51 +0200
committerTobias Klausmann <klausman@gentoo.org>2021-09-10 13:27:51 +0200
commitffacd0fb367cc352273cd2281dadcf45db1520f5 (patch)
treef909b91b88c8cc10e3250f37bf4296494d48e74c /dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
parentdev-python/flake8: remove deprecated v3.8.4 (diff)
downloadgentoo-ffacd0fb367cc352273cd2281dadcf45db1520f5.tar.gz
gentoo-ffacd0fb367cc352273cd2281dadcf45db1520f5.tar.bz2
gentoo-ffacd0fb367cc352273cd2281dadcf45db1520f5.zip
dev-python/pycodestyle: Restore 2.6.0
Package-Manager: Portage-3.0.22, Repoman-3.0.3 RepoMan-Options: --force Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Diffstat (limited to 'dev-python/pycodestyle/pycodestyle-2.6.0.ebuild')
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
new file mode 100644
index 000000000000..8d686c6ddfd0
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="https://pypi.org/project/pycodestyle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests setup.py
+distutils_enable_sphinx docs
+
+python_test() {
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
+}