summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:09:25 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:54:56 +0300
commit8c57c9a387ed3308dfd201e3dcc398205b0f021a (patch)
tree0bde922a96b43f7949943917c2d2f9f7e909a925 /dev-python/pycodestyle
parentdev-python/flask: add 2.2.1 (diff)
downloadgentoo-8c57c9a387ed3308dfd201e3dcc398205b0f021a.tar.gz
gentoo-8c57c9a387ed3308dfd201e3dcc398205b0f021a.tar.bz2
gentoo-8c57c9a387ed3308dfd201e3dcc398205b0f021a.zip
dev-python/pycodestyle: add 2.9.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest1
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.9.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index 9820de6c38bb..c5f52fc8d84f 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,2 +1,3 @@
DIST pycodestyle-2.8.0.tar.gz 102299 BLAKE2B ac4708a513582bb0f27f1abfcc983319e6c7b853c53971d5f026f297f897b25a6c8a651a4d2441b19ab37e6df6f7a38a472aad0757fec59e0438263d76ccfdb2 SHA512 0098be44451bc173507e2b396aaf342ccf7f25a6a1f5d5c1f802079a76a66e6bedf9f358b5e07b27bee66e3b279c72a6b72f63e5984f58ae83b7fc5806880fc1
DIST pycodestyle-2.9.0.tar.gz 102014 BLAKE2B ee2c2cad332e7442f9e557f388c3de09ea0ea65b0678c65d64d6293de18aa884a39a6a65ce47a99ac04b98da4e4bad14d2ccd228b22bdbd7361a3a0ca2c27afb SHA512 82926bf1c5b72decc0679d4fcec705d707b91b347ea0eec52b1f05301b96e55fc75afdb367ecdec674976fe1f2f7b475498a8e9a2ba19e3dfd483584a9ef841e
+DIST pycodestyle-2.9.1.tar.gz 102127 BLAKE2B 701e6325a73173b8ab8540f03f794066f05ffe7f29cfac49f065ec6f8cc6a50b1334372b8fd7619a368a54605dde0214da9e9b3b59326c58803bf7f49d6981ea SHA512 da1c67815b50d13c8eb70cebcc12c761a6407518a4ed4a8780ee7064089c9e89a5c3246d05f19916c0ec293fc1a372d3b2adb72e11f775b1cfbd1fbbe07a1a83
diff --git a/dev-python/pycodestyle/pycodestyle-2.9.1.ebuild b/dev-python/pycodestyle/pycodestyle-2.9.1.ebuild
new file mode 100644
index 000000000000..509d1524f65a
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="
+ https://pycodestyle.pycqa.org/en/latest/
+ https://github.com/PyCQA/pycodestyle/
+ https://pypi.org/project/pycodestyle/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local -x PYTHONPATH=${S}
+ "${EPYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die "Tests failed with ${EPYTHON}"
+ "${EPYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die "Tests failed with ${EPYTHON}"
+ "${EPYTHON}" pycodestyle.py --doctest -v || die "Tests failed with ${EPYTHON}"
+}