summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 14:28:18 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 14:58:40 +0100
commit5828e6032432732c70883db05e8ee3ecd3638ba1 (patch)
tree59aac3805cb6b05d4c6e243b8ab39f2c111dc26f /dev-python/pycparser
parentdev-python/pycparser: Stabilize 2.19-r1 ALLARCHES (diff)
downloadgentoo-5828e6032432732c70883db05e8ee3ecd3638ba1.tar.gz
gentoo-5828e6032432732c70883db05e8ee3ecd3638ba1.tar.bz2
gentoo-5828e6032432732c70883db05e8ee3ecd3638ba1.zip
dev-python/pycparser: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/Manifest2
-rw-r--r--dev-python/pycparser/files/pycparser-2.18-OO.patch56
-rw-r--r--dev-python/pycparser/pycparser-2.14.ebuild34
-rw-r--r--dev-python/pycparser/pycparser-2.18-r1.ebuild53
4 files changed, 0 insertions, 145 deletions
diff --git a/dev-python/pycparser/Manifest b/dev-python/pycparser/Manifest
index f87da52800d8..d57fc2733853 100644
--- a/dev-python/pycparser/Manifest
+++ b/dev-python/pycparser/Manifest
@@ -1,4 +1,2 @@
-DIST pycparser-2.14.tar.gz 223295 BLAKE2B 13dd4e36d7239db4fd6dfb77f08088bdbffa897ab75d748da5bd7297fe0a7dd751ba7153f8bf15f93494e347c653d1ebc7250907d2ccc555e785830e731e93dc SHA512 d5b9ab434a8944898ac23a4f51189db77b02b993bf3e3ca018852b117fc0eb43e460b156beaa5c1d631ad71c81e1649113e9fff7e33506b1e7d4de24d8b464c6
-DIST pycparser-2.18.tar.gz 245897 BLAKE2B 2f47263c73763f9d76edcb0d90aacd2e6cf0a68ed2e8c5825a0788a5ccb6574167220a5bb7605b2c11dda8956ce8fb1ad28eeb8e91fed7aa0282191b11478b63 SHA512 4754e4e7556d21da328bf7dbabf72f940c9b18f1457260d48208033b05e576919f45ab399e86ea49e82120116980d7d6f53e8b959d21b7b03a3b5bbea3672f13
DIST pycparser-2.19.tar.gz 158295 BLAKE2B 8836914e7549517f0c23a1c75457beefd013161f19c51a9f2a236ebd69466edd11235bf0a3f59c5cbece9e9e287eeb24b707bfa5afc30fcb079d134dcd4d9a80 SHA512 7f830e1c9066ee2d297a55e2bf6db4bf6447b6d9da0145d11a88c3bb98505755fb7986eafa6e06ae0b7680838f5e5d6a6d188245ca5ad45c2a727587bac93ab5
DIST pycparser-2.20.tar.gz 161330 BLAKE2B 9a114e4b73e6c3c495bd78c393957146ec425eb5b15d72266cbf424f15e8d2e2e6402ef36d60a9dff41b393aab80fe1356befd25549517f398e129836a76b037 SHA512 ff0853c9f981b43b4f2e879350715c07b02cf9dab223d4980d8fe0a3138c98041b5f848a9355ae4f1cb45e7f137c03a88843008e18d77af9250e0d9c55f5ca1b
diff --git a/dev-python/pycparser/files/pycparser-2.18-OO.patch b/dev-python/pycparser/files/pycparser-2.18-OO.patch
deleted file mode 100644
index ae42b2b9bd1d..000000000000
--- a/dev-python/pycparser/files/pycparser-2.18-OO.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 673accec311a027c22b0718d753f8da922915305 Mon Sep 17 00:00:00 2001
-From: Eli Bendersky <eliben@gmail.com>
-Date: Thu, 13 Jul 2017 20:25:29 -0700
-Subject: [PATCH] Address an import of pycparser in -OO mode.
-
-In this mode there are no docstrings; we don't want an instantiation of CParser
-to fail, though it won't actually work correctly if used.
-
-See #197 and #198
----
- pycparser/plyparser.py | 21 +++++++++++++++++++--
- 1 file changed, 19 insertions(+), 2 deletions(-)
-
-diff --git a/pycparser/plyparser.py b/pycparser/plyparser.py
-index af91922..b6640fa 100644
---- a/pycparser/plyparser.py
-+++ b/pycparser/plyparser.py
-@@ -8,6 +8,7 @@
- # License: BSD
- #-----------------------------------------------------------------
-
-+import warnings
-
- class Coord(object):
- """ Coordinates of a syntactic element. Consists of:
-@@ -87,12 +88,28 @@ def template(cls):
-
- See `parameterized` for more information on parameterized rules.
- """
-+ issued_nodoc_warning = False
- for attr_name in dir(cls):
- if attr_name.startswith('p_'):
- method = getattr(cls, attr_name)
- if hasattr(method, '_params'):
-- delattr(cls, attr_name) # Remove template method
-- _create_param_rules(cls, method)
-+ # Remove the template method
-+ delattr(cls, attr_name)
-+ # Create parameterized rules from this method; only run this if
-+ # the method has a docstring. This is to address an issue when
-+ # pycparser's users are installed in -OO mode which strips
-+ # docstrings away.
-+ # See: https://github.com/eliben/pycparser/pull/198/ and
-+ # https://github.com/eliben/pycparser/issues/197
-+ # for discussion.
-+ if method.__doc__ is not None:
-+ _create_param_rules(cls, method)
-+ elif not issued_nodoc_warning:
-+ warnings.warn(
-+ 'parsing methods must have __doc__ for pycparser to work properly',
-+ RuntimeWarning,
-+ stacklevel=2)
-+ issued_nodoc_warning = True
- return cls
-
-
diff --git a/dev-python/pycparser/pycparser-2.14.ebuild b/dev-python/pycparser/pycparser-2.14.ebuild
deleted file mode 100644
index 7c122a71fd48..000000000000
--- a/dev-python/pycparser/pycparser-2.14.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="C parser and AST generator written in Python"
-HOMEPAGE="https://github.com/eliben/pycparser"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_compile() {
- distutils-r1_python_compile
- pushd "${BUILD_DIR}/lib/pycparser" > /dev/null || die
- "${PYTHON}" _build_tables.py || die
- popd > /dev/null || die
-}
-
-python_test() {
- nosetests || die
-}
diff --git a/dev-python/pycparser/pycparser-2.18-r1.ebuild b/dev-python/pycparser/pycparser-2.18-r1.ebuild
deleted file mode 100644
index 20f5f714a28a..000000000000
--- a/dev-python/pycparser/pycparser-2.18-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="C parser and AST generator written in Python"
-HOMEPAGE="https://github.com/eliben/pycparser"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/pycparser-2.18-OO.patch
-)
-
-python_prepare_all() {
- # remove the original files to guarantee their regen
- rm pycparser/{c_ast,lextab,yacctab}.py || die
-
- # kill sys.path manipulations to force the tests to use built files
- sed -i -e '/sys\.path/d' tests/*.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- # note: tables built by py3.5+ are incompatible with older versions
- # because of 100 group limit of 're' module -- just generate them
- # separately optimized for each target instead
- pushd "${BUILD_DIR}"/lib/pycparser > /dev/null || die
- "${PYTHON}" _build_tables.py || die
- popd > /dev/null || die
-}
-
-python_test() {
- # change workdir to avoid '.' import
- nosetests -v -w tests || die
-}