summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-11 19:34:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-11 19:34:31 +0200
commit5b446a67125cf40dc7ee6d85e120c68c28a5d4c6 (patch)
treea020f895b0546436e2bbfb7149e86bbf359929a3 /dev-python/pycparser
parentdev-python/pyasn1: Remove old (diff)
downloadgentoo-5b446a67125cf40dc7ee6d85e120c68c28a5d4c6.tar.gz
gentoo-5b446a67125cf40dc7ee6d85e120c68c28a5d4c6.tar.bz2
gentoo-5b446a67125cf40dc7ee6d85e120c68c28a5d4c6.zip
dev-python/pycparser: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/Manifest1
-rw-r--r--dev-python/pycparser/pycparser-2.19-r1.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/pycparser/Manifest b/dev-python/pycparser/Manifest
index d57fc2733853..5ec1265d1176 100644
--- a/dev-python/pycparser/Manifest
+++ b/dev-python/pycparser/Manifest
@@ -1,2 +1 @@
-DIST pycparser-2.19.tar.gz 158295 BLAKE2B 8836914e7549517f0c23a1c75457beefd013161f19c51a9f2a236ebd69466edd11235bf0a3f59c5cbece9e9e287eeb24b707bfa5afc30fcb079d134dcd4d9a80 SHA512 7f830e1c9066ee2d297a55e2bf6db4bf6447b6d9da0145d11a88c3bb98505755fb7986eafa6e06ae0b7680838f5e5d6a6d188245ca5ad45c2a727587bac93ab5
DIST pycparser-2.20.tar.gz 161330 BLAKE2B 9a114e4b73e6c3c495bd78c393957146ec425eb5b15d72266cbf424f15e8d2e2e6402ef36d60a9dff41b393aab80fe1356befd25549517f398e129836a76b037 SHA512 ff0853c9f981b43b4f2e879350715c07b02cf9dab223d4980d8fe0a3138c98041b5f848a9355ae4f1cb45e7f137c03a88843008e18d77af9250e0d9c55f5ca1b
diff --git a/dev-python/pycparser/pycparser-2.19-r1.ebuild b/dev-python/pycparser/pycparser-2.19-r1.ebuild
deleted file mode 100644
index 758ae67d8282..000000000000
--- a/dev-python/pycparser/pycparser-2.19-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="C parser and AST generator written in Python"
-HOMEPAGE="https://github.com/eliben/pycparser"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # remove the original files to guarantee their regen
- rm pycparser/{c_ast,lextab,yacctab}.py || die
-
- # kill sys.path manipulations to force the tests to use built files
- sed -i -e '/sys\.path/d' tests/*.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- # note: tables built by py3.5+ are incompatible with older versions
- # because of 100 group limit of 're' module -- just generate them
- # separately optimized for each target instead
- pushd "${BUILD_DIR}"/lib/pycparser > /dev/null || die
- "${PYTHON}" _build_tables.py || die
- popd > /dev/null || die
-}
-
-python_test() {
- # change workdir to avoid '.' import
- nosetests -v -w tests || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- # setup.py generates {c_ast,lextab,yacctab}.py with bytecode disabled.
- python_optimize
-}