summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-22 10:36:28 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-22 10:39:21 +0300
commit4d86f6f91df18602616bdde9da864ee933f54942 (patch)
tree17d0d3584e30f20d51eb5fd2eba06bf85fe5a0a0 /dev-python/pydecomp
parentdev-python/pytest-xdist: Fix copy-pasted comments (diff)
downloadgentoo-4d86f6f91df18602616bdde9da864ee933f54942.tar.gz
gentoo-4d86f6f91df18602616bdde9da864ee933f54942.tar.bz2
gentoo-4d86f6f91df18602616bdde9da864ee933f54942.zip
dev-python/pydecomp: enable py3.10, EAPI=8, small cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pydecomp')
-rw-r--r--dev-python/pydecomp/metadata.xml1
-rw-r--r--dev-python/pydecomp/pydecomp-0.3-r1.ebuild18
-rw-r--r--dev-python/pydecomp/pydecomp-9999.ebuild27
3 files changed, 8 insertions, 38 deletions
diff --git a/dev-python/pydecomp/metadata.xml b/dev-python/pydecomp/metadata.xml
index 4f1b4fd4b797..dbf942eb8211 100644
--- a/dev-python/pydecomp/metadata.xml
+++ b/dev-python/pydecomp/metadata.xml
@@ -13,5 +13,6 @@
</longdescription>
<upstream>
<remote-id type="github">dol-sen/pyDeComp</remote-id>
+ <bugs-to>https://github.com/dol-sen/pyDeComp/issues</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pydecomp/pydecomp-0.3-r1.ebuild b/dev-python/pydecomp/pydecomp-0.3-r1.ebuild
index d2be8da9d372..89859791adb4 100644
--- a/dev-python/pydecomp/pydecomp-0.3-r1.ebuild
+++ b/dev-python/pydecomp/pydecomp-0.3-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1 python-r1
+inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
EGIT_BRANCH="master"
@@ -23,15 +23,3 @@ HOMEPAGE="https://github.com/dol-sen/pyDeComp"
LICENSE="BSD"
SLOT="0"
-IUSE=""
-
-python_install_all() {
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- einfo
- einfo "Please file any enhancement requests, or bugs"
- einfo "at https://github.com/dol-sen/pyDeComp/issues"
- einfo "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
-}
diff --git a/dev-python/pydecomp/pydecomp-9999.ebuild b/dev-python/pydecomp/pydecomp-9999.ebuild
index 1fbc9bfe62dd..007ab948ae8d 100644
--- a/dev-python/pydecomp/pydecomp-9999.ebuild
+++ b/dev-python/pydecomp/pydecomp-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1 python-r1
+inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
EGIT_BRANCH="master"
@@ -14,7 +14,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
S="${WORKDIR}/pyDeComp-${PV}"
fi
@@ -23,22 +23,3 @@ HOMEPAGE="https://github.com/dol-sen/pyDeComp"
LICENSE="BSD"
SLOT="0"
-IUSE=""
-
-python_install_all() {
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- einfo
- einfo "This is new software."
- einfo "The API's it installs should be considered unstable"
- einfo "and are subject to change."
- einfo
- einfo "Please file any enhancement requests, or bugs"
- einfo "at https://github.com/dol-sen/pyDeComp/issues"
- einfo "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
- einfo
- ewarn "There may be some python 3 compatibility issues still."
- ewarn "Please help debug/fix/report them in github or bugzilla."
-}