summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-19 19:11:08 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-19 19:14:34 -0400
commit9d31b621e12c0c51a6866c1f2235828f75cc66fc (patch)
tree26cefa866fb94d6a01bbff4fc4b818f5e4fe2ef1 /dev-python/pydot/pydot-1.2.3.ebuild
parentprofiles: Improve kde-apps/ package removal messages (diff)
downloadgentoo-9d31b621e12c0c51a6866c1f2235828f75cc66fc.tar.gz
gentoo-9d31b621e12c0c51a6866c1f2235828f75cc66fc.tar.bz2
gentoo-9d31b621e12c0c51a6866c1f2235828f75cc66fc.zip
media-gfx/pydot: move to dev-python/pydot
Diffstat (limited to 'dev-python/pydot/pydot-1.2.3.ebuild')
-rw-r--r--dev-python/pydot/pydot-1.2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pydot/pydot-1.2.3.ebuild b/dev-python/pydot/pydot-1.2.3.ebuild
new file mode 100644
index 000000000000..0a313e45f150
--- /dev/null
+++ b/dev-python/pydot/pydot-1.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="https://github.com/erocarrera/pydot https://pypi.python.org/pypi/pydot"
+# pypi releases don't include tests
+SRC_URI="https://github.com/erocarrera/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
+}