summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-25 16:36:33 +0000
committerSam James <sam@gentoo.org>2022-01-25 16:37:01 +0000
commit7af44660abd549790aa07d42794f0603ac8fcd19 (patch)
tree8df8dde4aad6f65c9901f046922bf4ee9751cf37 /dev-python/pydot/pydot-1.4.2-r2.ebuild
parentnet-analyzer/vnstat: add 2.9 (diff)
downloadgentoo-7af44660abd549790aa07d42794f0603ac8fcd19.tar.gz
gentoo-7af44660abd549790aa07d42794f0603ac8fcd19.tar.bz2
gentoo-7af44660abd549790aa07d42794f0603ac8fcd19.zip
dev-python/pydot: actually enable patch for pyparsing-3
Closes: https://bugs.gentoo.org/830676 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pydot/pydot-1.4.2-r2.ebuild')
-rw-r--r--dev-python/pydot/pydot-1.4.2-r2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pydot/pydot-1.4.2-r2.ebuild b/dev-python/pydot/pydot-1.4.2-r2.ebuild
deleted file mode 100644
index db3881e7fab5..000000000000
--- a/dev-python/pydot/pydot-1.4.2-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python interface to Graphviz's Dot language"
-HOMEPAGE="https://github.com/pydot/pydot https://pypi.org/project/pydot/"
-# pypi releases don't include tests
-SRC_URI="https://github.com/pydot/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pyparsing[${PYTHON_USEDEP}]
- media-gfx/graphviz"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/chardet[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
-# "${FILESDIR}"/${PN}-1.4.2-pyparsing-3.patch
-)
-
-python_test() {
- cd test || die
- "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
-}