summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-03 05:30:10 +0000
committerSam James <sam@gentoo.org>2021-12-03 05:30:10 +0000
commitd2337b95715fa5c0855099178e655633dcecc4ec (patch)
treea44c91d95fa67d83db9141066a803d5eef6c702d /dev-python/pydot/pydot-1.4.2.ebuild
parentnet-libs/gnutls: adapt for OpenSSL bindist changes (diff)
downloadgentoo-d2337b95715fa5c0855099178e655633dcecc4ec.tar.gz
gentoo-d2337b95715fa5c0855099178e655633dcecc4ec.tar.bz2
gentoo-d2337b95715fa5c0855099178e655633dcecc4ec.zip
dev-python/pydot: add upper bound on pyparsing
Bug: https://github.com/pydot/pydot/issues/277 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pydot/pydot-1.4.2.ebuild')
-rw-r--r--dev-python/pydot/pydot-1.4.2.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/pydot/pydot-1.4.2.ebuild b/dev-python/pydot/pydot-1.4.2.ebuild
deleted file mode 100644
index 32771d419cfa..000000000000
--- a/dev-python/pydot/pydot-1.4.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface to Graphviz's Dot language"
-HOMEPAGE="https://github.com/pydot/pydot https://pypi.org/project/pydot/"
-# pypi releases don't include tests
-SRC_URI="https://github.com/pydot/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyparsing-2.1.4[${PYTHON_USEDEP}]
- media-gfx/graphviz"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/chardet[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- cd test || die
- "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
-}