summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-13 10:39:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-13 13:14:04 +0200
commit1ee576421e58424cd65764c42ff9ec08f50af940 (patch)
treeb08493d1c2afd3d839e1ac4b7850e63feabf8189 /dev-python/pydot
parentdev-python/pandas: Port to py3.8 (diff)
downloadgentoo-1ee576421e58424cd65764c42ff9ec08f50af940.tar.gz
gentoo-1ee576421e58424cd65764c42ff9ec08f50af940.tar.bz2
gentoo-1ee576421e58424cd65764c42ff9ec08f50af940.zip
dev-python/pydot: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydot')
-rw-r--r--dev-python/pydot/pydot-1.4.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/pydot/pydot-1.4.1.ebuild b/dev-python/pydot/pydot-1.4.1.ebuild
index b740101098cc..224ae09f8d9f 100644
--- a/dev-python/pydot/pydot-1.4.1.ebuild
+++ b/dev-python/pydot/pydot-1.4.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -20,9 +20,11 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/pyparsing-2.1.4[${PYTHON_USEDEP}]
media-gfx/graphviz"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )"
PATCHES=(
"${FILESDIR}"/${P}-unittest.patch