summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-23 21:43:02 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-23 21:43:19 +0000
commit1e710dcc7ce830f24cd23998816c4dbb10e7664e (patch)
tree11707decdf70b8ca992557448975670f2305f713 /dev-python/pyds9
parentx11-libs/xpa: Version bump (diff)
downloadgentoo-1e710dcc7ce830f24cd23998816c4dbb10e7664e.tar.gz
gentoo-1e710dcc7ce830f24cd23998816c4dbb10e7664e.tar.bz2
gentoo-1e710dcc7ce830f24cd23998816c4dbb10e7664e.zip
dev-python/pyds9: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/pyds9')
-rw-r--r--dev-python/pyds9/Manifest1
-rw-r--r--dev-python/pyds9/files/pyds9-1.8.1-use-system-xpa.patch36
-rw-r--r--dev-python/pyds9/pyds9-1.8.1.ebuild26
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyds9/Manifest b/dev-python/pyds9/Manifest
index 5e55965a090e..f4e02190e2ce 100644
--- a/dev-python/pyds9/Manifest
+++ b/dev-python/pyds9/Manifest
@@ -1 +1,2 @@
DIST pyds9-1.7.tar.gz 879882 SHA256 026a86827fa93f074e2a90b9d831ba79253f312fa331f6a6a508cfa91fa81aac SHA512 8622cf40db65228553abc2f3dea346d9c948706a2681217a9383589d4df0143c42ef859dff12689f699b0fb40806945232c336539f37eb2c78754f9779043bcb WHIRLPOOL abc2d11817519e844f61319b0ba30276a9bb48b6a3beb5e6b7c097717cc86aeeb1960f58d62a21a9ce5d4bc37c05b8cee181abc1cc12e2821a5e878d64f1f175
+DIST pyds9-1.8.1.tar.gz 899377 SHA256 86ebc33b4f493998751a2f4a1c0141c7a4a7aee2ab01b62119bcd75bb3ca7273 SHA512 6924ba2a1c1ccd0b3c068d4923c6a35127da744b91b97ece7d075bfde68ff49e6d24ae55869aa5e0e462f3f488db697dcdb33d217b33b6d63551286d9a95eec9 WHIRLPOOL 68bdbe1b10fc6c2651d20968eb8e419d1649958d4c0f70bff01ca7a9ad69fad7a8c78eaced497b6a5b0627f6de63f7390c3fdf009947faa5d25276174ea97fc7
diff --git a/dev-python/pyds9/files/pyds9-1.8.1-use-system-xpa.patch b/dev-python/pyds9/files/pyds9-1.8.1-use-system-xpa.patch
new file mode 100644
index 000000000000..b84994f76b08
--- /dev/null
+++ b/dev-python/pyds9/files/pyds9-1.8.1-use-system-xpa.patch
@@ -0,0 +1,36 @@
+Author: Ole Streicher <debian@liska.ath.cx>
+Description: Don't install and use the convienience copy provided in the
+ source, but use the one installed by the "libxpa1" package.
+--- a/setup.py
++++ b/setup.py
+@@ -21,7 +21,7 @@
+ xpadir = 'xpa'
+
+
+-def make(which):
++def _disabled_make(which):
+ curdir = os.getcwd()
+ srcDir = os.path.join(os.path.dirname(os.path.abspath(__file__)), xpadir)
+ os.chdir(srcDir)
+@@ -86,10 +86,5 @@
+ author_email='saord@cfa.harvard.edu',
+ url='http://hea-www.harvard.edu/saord/ds9/',
+ py_modules=['pyds9', 'xpa'],
+- data_files=[('', [os.path.join(xpadir, xpalib),
+- os.path.join(xpadir, xpans)])],
+- cmdclass={'build_py': my_build_py,
+- 'install_data': my_install_data,
+- 'clean': my_clean},
+ install_requires=['six']
+ )
+--- a/xpa.py
++++ b/xpa.py
+@@ -28,7 +28,7 @@
+ return _fname
+ return None
+
+-_libpath = _find_shlib('xpa')
++_libpath = 'libxpa.so.1'
+ if _libpath:
+ libxpa = ctypes.cdll.LoadLibrary(_libpath)
+ _ulist = platform.uname()
diff --git a/dev-python/pyds9/pyds9-1.8.1.ebuild b/dev-python/pyds9/pyds9-1.8.1.ebuild
new file mode 100644
index 000000000000..e201c4ceed24
--- /dev/null
+++ b/dev-python/pyds9/pyds9-1.8.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to XPA to communicate with DS9"
+HOMEPAGE="https://github.com/ericmandel/pyds9"
+SRC_URI="https://github.com/ericmandel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="x11-libs/xpa:0
+ dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=(changelog README.md)
+
+PATCHES=( "${FILESDIR}/${P}-use-system-xpa.patch" )