summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyds')
-rw-r--r--dev-python/pyds/Manifest1
-rw-r--r--dev-python/pyds/files/pyds-0.6.5-py2.3.patch19
-rw-r--r--dev-python/pyds/files/pyds-pillow.patch14
-rw-r--r--dev-python/pyds/metadata.xml5
-rw-r--r--dev-python/pyds/pyds-0.7.3-r1.ebuild39
5 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pyds/Manifest b/dev-python/pyds/Manifest
new file mode 100644
index 000000000000..304ae359a076
--- /dev/null
+++ b/dev-python/pyds/Manifest
@@ -0,0 +1 @@
+DIST PyDS-0.7.3.tar.gz 660766 SHA256 9489a1e65e7df4d172223f863c601f7c09bc9101020cb8c0bbd8b884fbf055b7 SHA512 1ac395e9c93c04710c3ffc335c6ead8a4c35401959da3bf882906cf993e2dc316e52d567e218aca07beebc1b32b71abbeb3f92c7f673d2b613ea0bd62b654e6f WHIRLPOOL d5747f9e3dfa21331ce5bce48494c6031dfefb7acd233e8823ec8810c4e10ee490c3608ef9891ef56e77e038d16c34ffa944696bb290fd6dfbfdaaae81efa8ec
diff --git a/dev-python/pyds/files/pyds-0.6.5-py2.3.patch b/dev-python/pyds/files/pyds-0.6.5-py2.3.patch
new file mode 100644
index 000000000000..e32f7473a3ec
--- /dev/null
+++ b/dev-python/pyds/files/pyds-0.6.5-py2.3.patch
@@ -0,0 +1,19 @@
+--- PyDS/DownstreamTool.py
++++ PyDS/DownstreamTool.py
+@@ -36,6 +36,7 @@
+ import urllib
+ import gzip
+ import mimetypes
++import urlparse
+
+ import PyDS.Tool
+
+@@ -74,6 +75,8 @@
+ for h in self.cache._getUrlHeaders(theurl):
+ apply(self.addheader, h)
+ self.message += _('<br>adding Header "%s: %s"') % h
++ urlpieces = urlparse.urlparse(url[1])
++ url = (urlpieces[1], url[1])
+ res = urllib.URLopener.open_http(self, url, data)
+ self.message = self.message.replace('%', '%%')
+ if self.verbose:
diff --git a/dev-python/pyds/files/pyds-pillow.patch b/dev-python/pyds/files/pyds-pillow.patch
new file mode 100644
index 000000000000..505a86675e2c
--- /dev/null
+++ b/dev-python/pyds/files/pyds-pillow.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/show_bug.cgi?id=471508
+--- a/PyDS/PictureTool.py
++++ a/PyDS/PictureTool.py
+@@ -35,8 +35,8 @@
+ import string
+ import mimetypes
+
+-import Image
+-import ImageDraw
++from PIL import Image
++from PIL import ImageDraw
+
+ import PyDS.Tool
+ import PyDS.EXIF
diff --git a/dev-python/pyds/metadata.xml b/dev-python/pyds/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/pyds/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pyds/pyds-0.7.3-r1.ebuild b/dev-python/pyds/pyds-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..dbca1ca205c4
--- /dev/null
+++ b/dev-python/pyds/pyds-0.7.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="PyDS-${PV}"
+
+DESCRIPTION="Python Desktop Server"
+HOMEPAGE="http://pyds.muensterland.org/"
+SRC_URI="http://simon.bofh.ms/~gb/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-text/silvercity
+ >=dev-db/metakit-2.4.9.2[python,${PYTHON_USEDEP}]
+ >=dev-python/cheetah-0.9.15[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.3[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ >=dev-python/medusa-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyrex-0.5[${PYTHON_USEDEP}]
+ >=dev-python/soappy-0.11.1[${PYTHON_USEDEP}]
+ virtual/jpeg
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( OVERVIEW )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.5-py2.3.patch"
+ "${FILESDIR}/${PN}-pillow.patch"
+)