summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-31 07:50:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-10-31 08:12:29 +0100
commit714204e4d687aacf10ad00eaa93f83b8ef17d110 (patch)
treeeb7b494fc5e8c93b2b71f88bada567388f26bd78 /dev-python/pydyf/pydyf-0.1.2.ebuild
parentdev-python/importlib_resources: Bump to 5.4.0 (diff)
downloadgentoo-714204e4d687aacf10ad00eaa93f83b8ef17d110.tar.gz
gentoo-714204e4d687aacf10ad00eaa93f83b8ef17d110.tar.bz2
gentoo-714204e4d687aacf10ad00eaa93f83b8ef17d110.zip
dev-python/pydyf: Bump to 0.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydyf/pydyf-0.1.2.ebuild')
-rw-r--r--dev-python/pydyf/pydyf-0.1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pydyf/pydyf-0.1.2.ebuild b/dev-python/pydyf/pydyf-0.1.2.ebuild
new file mode 100644
index 000000000000..0ecfdfd4412d
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/"
+SRC_URI="
+ https://github.com/CourtBouillon/pydyf/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}