summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-18 11:57:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-18 12:00:04 +0100
commite0e146e3ef813156203c36626295049557fdf4fc (patch)
tree08fa9602bbc69e900784a13e74078a5e67c3db14 /dev-python/pyee/pyee-1.0.1.ebuild
parentsys-libs/newlib: update git repo location #572250 (diff)
downloadgentoo-e0e146e3ef813156203c36626295049557fdf4fc.tar.gz
gentoo-e0e146e3ef813156203c36626295049557fdf4fc.tar.bz2
gentoo-e0e146e3ef813156203c36626295049557fdf4fc.zip
dev-python/pyee: initial import; ebuild by me
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/pyee/pyee-1.0.1.ebuild')
-rw-r--r--dev-python/pyee/pyee-1.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyee/pyee-1.0.1.ebuild b/dev-python/pyee/pyee-1.0.1.ebuild
new file mode 100644
index 000000000000..cd07ea57ff1c
--- /dev/null
+++ b/dev-python/pyee/pyee-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A port of node.js's EventEmitter to python"
+HOMEPAGE="https://pypi.python.org/pypi/pyee https://github.com/jfhbrook/pyee"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v || die
+}