summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 21:15:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 22:19:41 +0200
commiteceef75b4e3f0906eb641426efe6e922da77274c (patch)
treef8c8c9a492db4429f1e715af2ec0e45d19a0adc2 /dev-python/pyfakefs/pyfakefs-4.1.0.ebuild
parentdev-python/argcomplete: Bump to 1.12.0 (diff)
downloadgentoo-eceef75b4e3f0906eb641426efe6e922da77274c.tar.gz
gentoo-eceef75b4e3f0906eb641426efe6e922da77274c.tar.bz2
gentoo-eceef75b4e3f0906eb641426efe6e922da77274c.zip
dev-python/pyfakefs: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs/pyfakefs-4.1.0.ebuild')
-rw-r--r--dev-python/pyfakefs/pyfakefs-4.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/pyfakefs-4.1.0.ebuild b/dev-python/pyfakefs/pyfakefs-4.1.0.ebuild
new file mode 100644
index 000000000000..f1b37e17b4b5
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-4.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="a fake file system that mocks the Python file system modules"
+HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
+SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-openpyxl.patch
+)
+
+python_test() {
+ "${EPYTHON}" -m pyfakefs.tests.all_tests -v || die "tests failed under ${EPYTHON}"
+}