summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-02 04:53:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-02 04:53:16 +0200
commit105526069f1c27b9d4f348b6a917d8280ece74fb (patch)
tree8b8623a0071198b566b34184558809b60054be07 /dev-python/pyflakes
parentdev-python/pycodestyle: Remove old (diff)
downloadgentoo-105526069f1c27b9d4f348b6a917d8280ece74fb.tar.gz
gentoo-105526069f1c27b9d4f348b6a917d8280ece74fb.tar.bz2
gentoo-105526069f1c27b9d4f348b6a917d8280ece74fb.zip
dev-python/pyflakes: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyflakes')
-rw-r--r--dev-python/pyflakes/Manifest1
-rw-r--r--dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch38
-rw-r--r--dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild25
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pyflakes/Manifest b/dev-python/pyflakes/Manifest
index 49d6006afee4..d41a6df6e299 100644
--- a/dev-python/pyflakes/Manifest
+++ b/dev-python/pyflakes/Manifest
@@ -1,2 +1 @@
-DIST pyflakes-3.0.1.tar.gz 63554 BLAKE2B 992dc4c81204c9ae2fd44744452e76a11209552edaef930edb14b7ba4763720cd1c0c0cd148fa7edd474b33aa529d8ec28f7f35a2b02b707d58cf70243fc13a9 SHA512 10ffe2b92f3885d40578452423a93609f8546b2392997bdbc3f64ca0094516ce6b8449e5d3675bda5fdbc16190c89be23609559fc4cd4f1c97e6af032226d7b7
DIST pyflakes-3.1.0.tar.gz 63636 BLAKE2B 89e5fae6bba9efc820e348ddac37fd8590478c64363a5f295cc620ebbc7b51d4d51e0cff30b6a54ee573612e5309d7fff9462bc31c9e89c34cf7cdbecffabd30 SHA512 6277eaa82a3d94f8052b3da865cfcc8e99846738b5869fca1be92bb5b9a4db0088859d811da565200e640ad0555d46e0ebcaf831cd422b84304514592270b02e
diff --git a/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch b/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch
deleted file mode 100644
index db804f42c775..000000000000
--- a/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-https://github.com/PyCQA/pyflakes/commit/836631f2f73d45baa4021453d89fc9fd6f52be58
-https://bugs.gentoo.org/909554
-
-From 836631f2f73d45baa4021453d89fc9fd6f52be58 Mon Sep 17 00:00:00 2001
-From: Anthony Sottile <asottile@umich.edu>
-Date: Mon, 12 Jun 2023 21:00:45 -0400
-Subject: [PATCH] fix error reporter and testsuite in 3.11.4+ (#775)
-
---- a/pyflakes/reporter.py
-+++ b/pyflakes/reporter.py
-@@ -56,8 +56,9 @@ def syntaxError(self, filename, msg, lineno, offset, text):
- else:
- line = text.splitlines()[-1]
-
-+ # lineno might be None if the error was during tokenization
- # lineno might be 0 if the error came from stdin
-- lineno = max(lineno, 1)
-+ lineno = max(lineno or 0, 1)
-
- if offset is not None:
- # some versions of python emit an offset of -1 for certain encoding errors
---- a/pyflakes/test/test_api.py
-+++ b/pyflakes/test/test_api.py
-@@ -621,8 +621,12 @@ def test_misencodedFileUTF16(self):
- x = "%s"
- """ % SNOWMAN).encode('utf-16')
- with self.makeTempFile(source) as sourcePath:
-- self.assertHasErrors(
-- sourcePath, [f"{sourcePath}: problem decoding source\n"])
-+ if sys.version_info < (3, 11, 4):
-+ expected = f"{sourcePath}: problem decoding source\n"
-+ else:
-+ expected = f"{sourcePath}:1: source code string cannot contain null bytes\n" # noqa: E501
-+
-+ self.assertHasErrors(sourcePath, [expected])
-
- def test_checkRecursive(self):
- """
diff --git a/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild b/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild
deleted file mode 100644
index 4060d6d1f972..000000000000
--- a/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Passive checker for Python programs"
-HOMEPAGE="
- https://github.com/PyCQA/pyflakes/
- https://pypi.org/project/pyflakes/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python3.11.patch
-)
-
-distutils_enable_tests unittest