summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-05 12:07:16 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-05 12:25:03 +0100
commit396fdb4ee3e71bf6ec6964e8660dcb8f4c2b16c1 (patch)
treed81987bf05bb6e0b8feae96aa6cc77d5b432b3d6 /dev-python/pyflakes
parentdev-python/pysol-cards: Bump to 0.16.0 (diff)
downloadgentoo-396fdb4ee3e71bf6ec6964e8660dcb8f4c2b16c1.tar.gz
gentoo-396fdb4ee3e71bf6ec6964e8660dcb8f4c2b16c1.tar.bz2
gentoo-396fdb4ee3e71bf6ec6964e8660dcb8f4c2b16c1.zip
dev-python/pyflakes: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyflakes')
-rw-r--r--dev-python/pyflakes/Manifest1
-rw-r--r--dev-python/pyflakes/pyflakes-3.2.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyflakes/Manifest b/dev-python/pyflakes/Manifest
index d41a6df6e299..42038af8cbb0 100644
--- a/dev-python/pyflakes/Manifest
+++ b/dev-python/pyflakes/Manifest
@@ -1 +1,2 @@
DIST pyflakes-3.1.0.tar.gz 63636 BLAKE2B 89e5fae6bba9efc820e348ddac37fd8590478c64363a5f295cc620ebbc7b51d4d51e0cff30b6a54ee573612e5309d7fff9462bc31c9e89c34cf7cdbecffabd30 SHA512 6277eaa82a3d94f8052b3da865cfcc8e99846738b5869fca1be92bb5b9a4db0088859d811da565200e640ad0555d46e0ebcaf831cd422b84304514592270b02e
+DIST pyflakes-3.2.0.tar.gz 63788 BLAKE2B 12547bc1ef69d11efb86198c091072085df8a5435608aace18eab9da92b428980ad62fc4b7b6e182bee7963c511b637c17191db9138fc811256f553b902dbd66 SHA512 bd413b2ad80ae942bc13cef5ecb3a47b09abb0641fe468d427717b32895eb1702c9e8831867fbaa1de6fff71ab16bc3dae96f745bbc3e7d99de104a008f397ba
diff --git a/dev-python/pyflakes/pyflakes-3.2.0.ebuild b/dev-python/pyflakes/pyflakes-3.2.0.ebuild
new file mode 100644
index 000000000000..65b5994d6679
--- /dev/null
+++ b/dev-python/pyflakes/pyflakes-3.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Passive checker for Python programs"
+HOMEPAGE="
+ https://github.com/PyCQA/pyflakes/
+ https://pypi.org/project/pyflakes/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # regressions with pypy3.10
+ # https://github.com/PyCQA/pyflakes/issues/779
+ EPYTEST_DESELECT+=(
+ pyflakes/test/test_api.py::CheckTests::test_eofSyntaxError
+ pyflakes/test/test_api.py::CheckTests::test_misencodedFileUTF8
+ pyflakes/test/test_api.py::CheckTests::test_multilineSyntaxError
+ )
+ fi
+
+ epytest
+}