summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2023-07-30 12:03:51 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2023-07-30 12:04:46 +0200
commitc40318645b693df675c7a85095406e219e120c81 (patch)
treeec27042f7fcbba90f9078c904b667df00bf5352a /dev-python/pyfuse3/pyfuse3-3.2.3-r1.ebuild
parentdev-ruby/reline: add 0.3.7 (diff)
downloadgentoo-c40318645b693df675c7a85095406e219e120c81.tar.gz
gentoo-c40318645b693df675c7a85095406e219e120c81.tar.bz2
gentoo-c40318645b693df675c7a85095406e219e120c81.zip
dev-python/pyfuse3: <cython-3 dep; py3.12 support.
Bug: https://bugs.gentoo.org/911152 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'dev-python/pyfuse3/pyfuse3-3.2.3-r1.ebuild')
-rw-r--r--dev-python/pyfuse3/pyfuse3-3.2.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyfuse3/pyfuse3-3.2.3-r1.ebuild b/dev-python/pyfuse3/pyfuse3-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..ac0793e4562c
--- /dev/null
+++ b/dev-python/pyfuse3/pyfuse3-3.2.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python 3 bindings for libfuse 3 with asynchronous API"
+HOMEPAGE="
+ https://github.com/libfuse/pyfuse3/
+ https://pypi.org/project/pyfuse3/
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-fs/fuse:3
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/trio[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_configure() {
+ esetup.py build_cython
+}