summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-28 20:30:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-28 20:33:04 +0200
commitc98f77f83d1309117f852d27b8f29d588902a6bf (patch)
treef837ff1d285ac107dbfd8f4156dd88e39709db01 /dev-python/pyfuse3
parentdev-python/Levenshtein: Bump to 0.20.5 (diff)
downloadgentoo-c98f77f83d1309117f852d27b8f29d588902a6bf.tar.gz
gentoo-c98f77f83d1309117f852d27b8f29d588902a6bf.tar.bz2
gentoo-c98f77f83d1309117f852d27b8f29d588902a6bf.zip
dev-python/pyfuse3: Bump to 3.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfuse3')
-rw-r--r--dev-python/pyfuse3/Manifest1
-rw-r--r--dev-python/pyfuse3/pyfuse3-3.2.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyfuse3/Manifest b/dev-python/pyfuse3/Manifest
index e1db1f7198d8..11525080ab8d 100644
--- a/dev-python/pyfuse3/Manifest
+++ b/dev-python/pyfuse3/Manifest
@@ -1 +1,2 @@
DIST pyfuse3-3.2.1.tar.gz 509083 BLAKE2B 16ada8aec47d8049907ef2710e9bfdf7991a8127560e7264e4eb58f7062efde478d2914597333991be4a6ef67a2a83c470560456287c1298b2008454ac831fb0 SHA512 468ef4cf9e2caef346a108f481a4c6dca8909ff3ea5aed11187df4c70c72c6180af9004348d25648368598495e5a5d9be2ba95d37f4d6d8a8c982f4893471b04
+DIST pyfuse3-3.2.2.tar.gz 510868 BLAKE2B a6f11083a3ddec031fdfe5cb810be526cba26d7bc9599a64d28e9a45281aeb04fca8728ff3788e44f1736475c89e64c3c1fd7cb964ff81fc30ce441a5dda7fae SHA512 91787c4198592ff5f0c022141e6c3cb1701108a6635b4d26347c4f7efff2a83aec206e939b44879ad1fd5c6c85aa6731b7465c998ec55ec032a6db024ffee817
diff --git a/dev-python/pyfuse3/pyfuse3-3.2.2.ebuild b/dev-python/pyfuse3/pyfuse3-3.2.2.ebuild
new file mode 100644
index 000000000000..e681ca0d9809
--- /dev/null
+++ b/dev-python/pyfuse3/pyfuse3-3.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 bindings for libfuse 3 with asynchronous API"
+HOMEPAGE="
+ https://github.com/libfuse/pyfuse3/
+ https://pypi.org/project/pyfuse3/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-fs/fuse:3
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/trio[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ sys-apps/which
+ )
+"
+
+distutils_enable_tests pytest
+
+python_configure() {
+ esetup.py build_cython
+}