summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-27 23:46:34 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-28 17:52:47 +0200
commit233157f3191a4bcc10981b83534e43bbf6d6cbfe (patch)
tree9cade884e0e3329d901ef1592febc57c5aad31ac /dev-python/pygame_sdl2
parentdev-python/olefile: Remove py2.7 in revbump (diff)
downloadgentoo-233157f3191a4bcc10981b83534e43bbf6d6cbfe.tar.gz
gentoo-233157f3191a4bcc10981b83534e43bbf6d6cbfe.tar.bz2
gentoo-233157f3191a4bcc10981b83534e43bbf6d6cbfe.zip
dev-python/pygame_sdl2: Remove py2.7 in revbump
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygame_sdl2')
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r2.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r2.ebuild
new file mode 100644
index 000000000000..0790013708f6
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+inherit distutils-r1
+
+PYSDL="${PN}-2.1.0"
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="https://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0=
+ media-libs/libsdl2:=[video]
+ media-libs/sdl2-image:=[png,jpeg]
+ >=media-libs/sdl2-mixer-2.0.2:=
+ media-libs/sdl2-ttf:=
+ virtual/jpeg:0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
+
+# PyGame distribution for this version has some pregenerated files;
+# we need to remove them
+python_prepare_all()
+{
+ rm -r gen{,3} || die
+ distutils-r1_python_prepare_all
+}