summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-10 08:29:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-10 08:58:10 +0100
commit35639796133aeeb6e6e9e50f639753d556f10f84 (patch)
tree0a39b82f47b90abac43d42266742bc25ab2f36b2 /dev-python/pyghmi
parentdev-python/Faker: Bump to 12.2.0 (diff)
downloadgentoo-35639796133aeeb6e6e9e50f639753d556f10f84.tar.gz
gentoo-35639796133aeeb6e6e9e50f639753d556f10f84.tar.bz2
gentoo-35639796133aeeb6e6e9e50f639753d556f10f84.zip
dev-python/pyghmi: Bump to 1.5.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.34.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index e2c981ab41b2..6dab38ab828b 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -2,3 +2,4 @@ DIST pyghmi-1.5.22.tar.gz 221963 BLAKE2B 6705e904c481ddbb241fc8f8089e6bc9bcc142b
DIST pyghmi-1.5.31.tar.gz 236574 BLAKE2B 9ee7250bae2d87f552686845ae3056f0f646cd1a383587c195bfcc6dfa476b8582509c909f0008fc6751295e2e4e7d33bf822e8b529d67306fcc85412fc9af22 SHA512 d7c9c05b51780bef9d2b417c1a586f84ec87a9f1ff578ab019bfdc1a462decd907b2634fb1c830d0e369eb97122bfcba62ce79a4386c73c9854cde8f9fdeb65c
DIST pyghmi-1.5.32.tar.gz 236662 BLAKE2B e2a58d1eb9c5000d1a7f6b795836fa617ac0847ff2e7c817a6bd65ffb9a1162546a25f890ba20400e4c8d5f72dda538f696c17a35542506cc171b80f99cb5a30 SHA512 b30ad1e200d23ed99280794e4e8e12c1a2412daa27e435183edbdcf57cb1d8ace8790845dd5ab0579f2a22b26eabc11e1d1f5845fb94fed019f461b9419d2763
DIST pyghmi-1.5.33.tar.gz 237980 BLAKE2B 3599c0f56b665129e0432faa9aaab8fdbc831ec8398a3eea2034e68cbf1f75638ecad7ce7ae4e7ac0d51a4a7ac502837da8d3c421e836c88214d82ed7d0bc901 SHA512 1e187f5824491e9d4f48c2f0a5578ced6916764b6bc4f442045e34f37bff85bf16e3ab88df29f8797b15293282112aa04e2f0a375498e96c8aa7b3c7005d22dc
+DIST pyghmi-1.5.34.tar.gz 239758 BLAKE2B 3347498d7c1dc0eed102569cc7bc7c2084c694853a5e33c4145dadf623dc9a3db398fa32dc8fc87717a1df2db15c0477cbf59b1eba4c23cf558b45abbf47308e SHA512 fc61d5f8814366e51964b30e29f632d774ec8f202e4c05bd973fbe74e11f560a706e4abd6e01e4ae52d72dff2608c6abe72b5c46941884e472f159d2e4063047
diff --git a/dev-python/pyghmi/pyghmi-1.5.34.ebuild b/dev-python/pyghmi/pyghmi-1.5.34.ebuild
new file mode 100644
index 000000000000..b5da25e535ba
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.34.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack-archive/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest