summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 09:30:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 10:05:34 +0200
commitf0632ccf3b0beae42d7b17117a973d91a1e0f5d1 (patch)
tree1f95df1eae67d3cecb04473e545a2c05eda018ef /dev-python/pyghmi
parentdev-python/traitlets: Bump to 5.2.0 (diff)
downloadgentoo-f0632ccf3b0beae42d7b17117a973d91a1e0f5d1.tar.gz
gentoo-f0632ccf3b0beae42d7b17117a973d91a1e0f5d1.tar.bz2
gentoo-f0632ccf3b0beae42d7b17117a973d91a1e0f5d1.zip
dev-python/pyghmi: Bump to 1.5.41
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.41.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 2d33aa5a176b..84d46972ed3b 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -3,3 +3,4 @@ DIST pyghmi-1.5.37.tar.gz 241173 BLAKE2B 7094150c6002b59e1fcd9b337987d3506928222
DIST pyghmi-1.5.38.tar.gz 241170 BLAKE2B f056fb985ca1281fc481bf9ccaa5a6c86a05655fa6d3055e4ef2d9823e2893fff7ce795aebca5fafca5a368836372a71c73b6d8210b458f1dc54e9b68e429d4c SHA512 8d134cf2fa4c1226debe383832141e36f77a465acf02b2fcdf1ba5b621bf23444f40c69b9ce98c0ad096a8f2e5e9b04b4d0627d25354b76a130bece8d75f91c8
DIST pyghmi-1.5.39.tar.gz 241157 BLAKE2B f406ad0dd6ae2b45c34aae14738f10c86f0a62082f7da2ab75b8e01558a9c0a8aa4c123cca935a0f3f03f5ae92d799d283dd81155d3c31c886555184f69be2b7 SHA512 efbc603002870edbeb4944207521077f5c25ed080578d3008a542a0e65d3769fe1da7105ed15d85acc3931a126a440e64b6ff9d88f6f4a3b66a5cdabcbab3e4c
DIST pyghmi-1.5.40.tar.gz 241230 BLAKE2B 265fc07c18fe17987340932d1b67bb631907a0b66832ca79794117ccff9bff99fcf9046f2d0911878b16b2b2e179fe05b0980e34ec9125895abeda1a7d04aca5 SHA512 3bf35fb68fa867689b3218963fc811a94d26072688eee5b1952d5694608d81b1fd6658bb335e96dac57513bff3ee8a10db83a79d6373a025a23c1ad0fba7b172
+DIST pyghmi-1.5.41.tar.gz 241325 BLAKE2B 40e69bea087c81b7375af96af65576eb4faacb0e52aba5bf9e719e4fe87bf9e320be79fdcfb7308e44a08e7da92d26ece8a483ba8489c04f0df0984300d94eab SHA512 80f859defc28c48c81deb4addb984d61a88eaa0fec1a9de8ab517001f16f8dabf6ce860142020f115158561e9cf75b4e8675fdd9aedeb7d9bd0ae3f38115e912
diff --git a/dev-python/pyghmi/pyghmi-1.5.41.ebuild b/dev-python/pyghmi/pyghmi-1.5.41.ebuild
new file mode 100644
index 000000000000..1844c945d4be
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.41.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest