summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-01 06:54:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-01 06:59:28 +0100
commitea865b0693ef295b6cc9b1e426cdc1d3f29775e6 (patch)
treef0d06af8eaae7a3de29ff08c443a0e36da675841 /dev-python/pygit2
parentnet-misc/chrome-remote-desktop: version bump to 80.0.3987.18 (diff)
downloadgentoo-ea865b0693ef295b6cc9b1e426cdc1d3f29775e6.tar.gz
gentoo-ea865b0693ef295b6cc9b1e426cdc1d3f29775e6.tar.bz2
gentoo-ea865b0693ef295b6cc9b1e426cdc1d3f29775e6.zip
dev-python/pygit2: Bump to 1.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.0.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 31e37ad20982..8964524e3c32 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,3 +1,4 @@
DIST pygit2-0.28.2.tar.gz 496469 BLAKE2B 1173401d4555f6f40eaf5a27d9c0e83214b66afa609f15cc4d689e8c58cc0ae3865b4e6ebb31808d354ecef56f3a74cc777fe42314ef348c39f1f61d82655bc9 SHA512 3f742cdcc9d603c9cc9ef2e0a545da8bcfb555a0bdeea1c73c53a284b43d40ad6b28c87a029578ad7b1c8f2bf56ecd2859dac8dd836474bfc66223ff4af9e8f0
DIST pygit2-1.0.1.tar.gz 501496 BLAKE2B 6a844a6ecab453f589f407acbd94aba46018a46374ba745ef50e72f4a5eda35103873287af7533ec963a297775eb3703151beec36984dfbcb68d751057c46c78 SHA512 c225204129cdfa41bcc50d76ff219602bfe910cdb77e246c49ecf5265b5a88c5c4803a7d107f4e00c4ec2f0b0d30e1a729d15413bdca8575d6ec23bb9420a90d
DIST pygit2-1.0.2.tar.gz 501736 BLAKE2B c8f1a7e4a3257af42d97b0fae8e14f26968e2be535e74863c97363e77e37774d929fa239bbb46982bd398a3c2032f3b3122bd42aa41760d3827a18b7b0b22663 SHA512 c76bf8ce2847ec8915201a714f076488a0dda4a790762293c02709b8b88a9a2b898f97e61565cf41cd11b10bebe2e1d76b5643ff2e86f9bf6a9517c87a988769
+DIST pygit2-1.0.3.tar.gz 501720 BLAKE2B ddfe228bb50df08c1b5e880f58be6b0ae111a10235b695ce93ef04b685507bda90cdccdacefd5400807cd19bc9c63b49061c2da73c89641fe9641c52a4ed16ab SHA512 debf4018e6daa938f44cf22f2acec1f850156e30ac44052e2edb8257f86a60453428356851cc495ae234df9cdbee922a6a7ad7886c9a6e3746b7315c71f0a3df
diff --git a/dev-python/pygit2/pygit2-1.0.3.ebuild b/dev-python/pygit2/pygit2-1.0.3.ebuild
new file mode 100644
index 000000000000..920c961be99e
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-libs/libgit2-0.28*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/def no_network/a \
+ return True' test/utils.py || die
+
+ # we need to move them away to prevent pytest from forcing '..'
+ # for imports
+ mkdir hack || die
+ mv test hack/ || die
+ ln -s hack/test test || die
+}
+
+python_test() {
+ pytest -vv hack/test || die
+}