summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 09:03:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 09:03:31 +0100
commitfcf2f835854862d91bf073907cb83fc280652605 (patch)
treeb2c5bc67a88d6aad66dee4fa3b06f77ab43bad5b /dev-python/pygit2
parentdev-python/tempora: Remove old (diff)
downloadgentoo-fcf2f835854862d91bf073907cb83fc280652605.tar.gz
gentoo-fcf2f835854862d91bf073907cb83fc280652605.tar.bz2
gentoo-fcf2f835854862d91bf073907cb83fc280652605.zip
dev-python/pygit2: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest2
-rw-r--r--dev-python/pygit2/pygit2-1.7.1.ebuild40
-rw-r--r--dev-python/pygit2/pygit2-1.8.0.ebuild42
3 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index cddd4b2024ef..8f8830d3e880 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,3 +1 @@
-DIST pygit2-1.7.1.tar.gz 281791 BLAKE2B 51f7f23752acf0abf6000f2262019db7503506267f0f5306bd53e0e15378447d2da564818c1b6efccc4759587aba6b4d7b142c760e4e2796445cd6056e949825 SHA512 a6232039b6364c7a0905aba20f7e27b43892b7067fa95fdd464438869453360ecdb885f2012cdf0eb0734c91dc79b60db894d1d0fee81922b9fb3cf920950937
-DIST pygit2-1.8.0.tar.gz 290516 BLAKE2B 3ec0035c5d9b7d15b62fdd15303f126ce005f99b632c2fb2a4a0294dac38458893d3fde137905862ede0286b2fb28d507c21092fe1a1178c3369b6b2fb07ee08 SHA512 f027331e1c0eae477048ac80b077361473dbddf2f137b0c6ebc0062a4b026e7fffd1fd7f6850f049dbbadb175a146b60eec87baf96f634e580a2d2237e40844c
DIST pygit2-1.9.0.gh.tar.gz 312349 BLAKE2B 067074d58887597cdce9b7bbebb96a8ec8629c4dc42c87c2a0a9a23849bc2e8e36763273c7d883ccfadbc9f71a3b4b5612a9a7b58e3cfb39475e568d85cbdc64 SHA512 8934f1099004a536b78973f74efc8854cbfb736369a0592c382fbc1325409105640235a2b3ce4602ad0dce863cb9ffd34b2359c9840d2abdadb55e2a43df18f9
diff --git a/dev-python/pygit2/pygit2-1.7.1.ebuild b/dev-python/pygit2/pygit2-1.7.1.ebuild
deleted file mode 100644
index e1df5178654a..000000000000
--- a/dev-python/pygit2/pygit2-1.7.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- =dev-libs/libgit2-1.3*:=
- >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # unconditionally prevent it from using network
- sed -i -e '/has_network/s:True:False:' test/utils.py || die
-
- # we need to move them away to prevent pytest from forcing '..'
- # for imports
- mkdir hack || die
- mv test hack/ || die
- ln -s hack/test test || die
-}
-
-python_test() {
- epytest hack/test
-}
diff --git a/dev-python/pygit2/pygit2-1.8.0.ebuild b/dev-python/pygit2/pygit2-1.8.0.ebuild
deleted file mode 100644
index 61462723957e..000000000000
--- a/dev-python/pygit2/pygit2-1.8.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- =dev-libs/libgit2-1.3*:=
-"
-BDEPEND="
- >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${DEPEND}
- ${BDEPEND}
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # unconditionally prevent it from using network
- sed -i -e '/has_network/s:True:False:' test/utils.py || die
-}
-
-src_test() {
- rm -r pygit2 || die
- distutils-r1_src_test
-}